summaryrefslogtreecommitdiff
path: root/pcr/tvenlinux-desktop/PKGBUILD
diff options
context:
space:
mode:
authorAurélien DESBRIÈRES <aurelien@hackers.camp>2014-06-13 20:27:30 +0200
committerAurélien DESBRIÈRES <aurelien@hackers.camp>2014-06-13 20:27:30 +0200
commit5023db87978b1ccbf63d7c0a534fe56a1fa0b6e3 (patch)
tree4fc4226e4ec653ba76af726e86e8dc8cb653fbf0 /pcr/tvenlinux-desktop/PKGBUILD
parentf18d2cb483f7df99671bcb598b21f6cbb58ce9fa (diff)
tvenlinux-desktop Simple bash script to watch and record TV
Diffstat (limited to 'pcr/tvenlinux-desktop/PKGBUILD')
-rw-r--r--pcr/tvenlinux-desktop/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/pcr/tvenlinux-desktop/PKGBUILD b/pcr/tvenlinux-desktop/PKGBUILD
new file mode 100644
index 000000000..0af13211d
--- /dev/null
+++ b/pcr/tvenlinux-desktop/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor (Arch) : ValHue <vhuelamo at gmail dot com>
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+# https://github.com/ValHue/AUR-PKGBUILDs
+
+pkgname=tvenlinux-desktop
+pkgver=20140127
+pkgrel=2
+pkgdesc="Simple bash script to watch and record TV on GNU/Linux/BSD without capture card/tuner. (TV in Spain, Peru, Chile, Cuba, Venezuela, Bolivia and Argentina)"
+url="http://www.tvenlinux.com/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('mplayer' 'rtmpdump')
+optdepends=('zenity: for GTK users' 'kdialog: for QT users' 'curl: for view EPG (Electronic Program Guide)')
+source=("http://www.tvenlinux.com/TVenLinux_2.sh" "http://www.tvenlinux.com/busi_tv.png")
+
+_pkgname="TVenLinux"
+
+_pkgname_desktop="#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=TVenLinux
+Exec=TVenLinux
+Icon=TVenLinux
+Type=Application
+Comment=Script to view more than 160 channels in Spanish TDT.
+Comment[es]=Script para ver más de 160 canales de TDT en Español.
+Terminal=false
+Categories=GNOME;AudioVideo;P2P;Video;TV;GTK;
+MimeType=x-scheme-handler/sop;"
+
+pkgver() {
+ cd "${srcdir}"
+ cat TVenLinux_2.sh | grep -e 'V_script=' | sed -e 's/V_script=//;s/"//g;s/;//;s/\///g;s/^\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)/\5\6\7\8\3\4\1\2/'
+}
+
+build() {
+ cd "${srcdir}"
+ mv busi_tv.png ${_pkgname}.png
+ echo -e "${_pkgname_desktop}" | tee ${_pkgname}.desktop
+}
+
+package() {
+ cd "${srcdir}"
+ install -d ${pkgdir}/usr/share/applications
+ install -d ${pkgdir}/usr/share/pixmaps
+ install -d ${pkgdir}/usr/bin
+ install -m 755 ${_pkgname}_2.sh ${pkgdir}/usr/bin/${_pkgname}
+ install -m 644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications
+ install -m 644 ${_pkgname}.png ${pkgdir}/usr/share/pixmaps
+}