summaryrefslogtreecommitdiff
path: root/pcr/tvenlinux-desktop/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-05-21 19:52:56 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-05-21 19:52:56 -0500
commitc2451fae4e0587fff47d59184def3a5b379de489 (patch)
treebb29f314bfa2ebebad747164efca74c0658faa81 /pcr/tvenlinux-desktop/PKGBUILD
parente28b4b6d6b962faa75a67509e2da1fd25863c4eb (diff)
tvenlinux-desktop-20140601-1: updating version
Diffstat (limited to 'pcr/tvenlinux-desktop/PKGBUILD')
-rw-r--r--pcr/tvenlinux-desktop/PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/pcr/tvenlinux-desktop/PKGBUILD b/pcr/tvenlinux-desktop/PKGBUILD
index 8f92787aa..33062cbf6 100644
--- a/pcr/tvenlinux-desktop/PKGBUILD
+++ b/pcr/tvenlinux-desktop/PKGBUILD
@@ -1,17 +1,19 @@
-# Contributor (Arch) : ValHue <vhuelamo at gmail dot com>
-# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+# Maintainer (Arch): ValHue <vhuelamo at gmail dot com>
+# Maintainer: Aurélien DESBRIÈRES <aurelien@hackers.camp>
# https://github.com/ValHue/AUR-PKGBUILDs
pkgname=tvenlinux-desktop
-pkgver=20140127
-pkgrel=2
+pkgver=20140601
+pkgrel=1
pkgdesc="Simple bash script to watch and record TV on GNU/Linux/BSD without capture card/tuner. (TV in Spain, Peru, Chile, Cuba, Venezuela, Bolivia and Argentina)"
url="http://www.tvenlinux.com/"
-arch=('i686' 'x86_64' 'mips64el')
+arch=('i686' 'x86_64')
license=('GPL3')
depends=('mplayer' 'rtmpdump')
optdepends=('zenity: for GTK users' 'kdialog: for QT users' 'curl: for view EPG (Electronic Program Guide)')
-source=("http://www.tvenlinux.com/TVenLinux_2.sh" "http://www.tvenlinux.com/busi_tv.png")
+source=("http://www.tvenlinux.com/TVenLinux.sh" "http://www.tvenlinux.com/busi_tv.png")
+md5sums=('a8f1c8d9d87f84e29bcca2de1656a3fd'
+ '57fe139851d8227320dc2b78a9390dd6')
_pkgname="TVenLinux"
@@ -29,7 +31,7 @@ MimeType=x-scheme-handler/sop;"
pkgver() {
cd "${srcdir}"
- cat TVenLinux_2.sh | grep -e 'V_script=' | sed -e 's/V_script=//;s/"//g;s/;//;s/\///g;s/^\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)/\5\6\7\8\3\4\1\2/'
+ cat TVenLinux.sh | grep -e 'V_script=' | sed -e 's/V_script=//;s/"//g;s/;//;s/\///g;s/^\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)\(.\)/\5\6\7\8\3\4\1\2/'
}
build() {
@@ -43,7 +45,7 @@ package() {
install -d ${pkgdir}/usr/share/applications
install -d ${pkgdir}/usr/share/pixmaps
install -d ${pkgdir}/usr/bin
- install -m 755 ${_pkgname}_2.sh ${pkgdir}/usr/bin/${_pkgname}
+ install -m 755 ${_pkgname}.sh ${pkgdir}/usr/bin/${_pkgname}
install -m 644 ${_pkgname}.desktop ${pkgdir}/usr/share/applications
install -m 644 ${_pkgname}.png ${pkgdir}/usr/share/pixmaps
}