summaryrefslogtreecommitdiff
path: root/pcr/ucommon/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-23 05:38:41 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-23 05:38:41 +0100
commit92e1e43ef32cef0c36c08b386041cb1de89b3950 (patch)
tree253e96884a30ffce8f87f1908bc156a36cb34ca2 /pcr/ucommon/PKGBUILD
parent7f51bf94108bfabf5a8b619134dd69d020dd4b4e (diff)
pcr/ucommon: updated to 7.0.0
Diffstat (limited to 'pcr/ucommon/PKGBUILD')
-rw-r--r--pcr/ucommon/PKGBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/pcr/ucommon/PKGBUILD b/pcr/ucommon/PKGBUILD
index ec34d126e..f05abb83b 100644
--- a/pcr/ucommon/PKGBUILD
+++ b/pcr/ucommon/PKGBUILD
@@ -1,28 +1,34 @@
-# Maintainer (Arch): Dan Serban
-# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
-# Contributor (Arch): David Zaragoza <david@zaragoza.com.ve>
+# Maintainer (AUR): Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor (AUR): Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+# parabola changes and rationale:
+# no changes.
pkgname=ucommon
-pkgver=5.0.6
+pkgver=7.0.0
pkgrel=1
pkgdesc="A light-weight C++ library to facilitate using C++ design patterns"
-arch=(i686 x86_64)
-url="http://www.gnutelephony.org/index.php/GNU_uCommon_C%2B%2B"
-license=(GPL)
-depends=(openssl)
-options=('!libtool')
-source=("http://ftp.gnu.org/gnu/commoncpp/${pkgname}-${pkgver}.tar.gz")
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.gnutelephony.org/index.php/GNU_uCommon_C++"
+license=('LGPL3')
+depends=('gnutls')
+source=("http://ftp.gnu.org/pub/gnu/commoncpp/$pkgname-$pkgver.tar.gz"{,.sig})
+md5sums=('90468af8f6692f0b6576189927414a39'
+ 'SKIP')
+validpgpkeys=('5CF995AAD5CC1E4079F76C38B1732A9CB37C87BA')
-build()
-{
- cd "${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --with-sslstack=gnu --enable-socks --enable-stdcpp --enable-atomics --with-pkg-config
make
}
-package()
-{
- cd "${pkgname}-${pkgver}"
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}
-md5sums=('86958df511e66bb6ea099b6ca3c3b582')