summaryrefslogtreecommitdiff
path: root/pcr/ucsniff-ace/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-20 09:10:03 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-20 09:13:21 +0100
commit92e417e74221c2101828ef2b66a77c7fdcd29433 (patch)
treea3aed88713defa5061cf7153d61701323ff36242 /pcr/ucsniff-ace/PKGBUILD
parentf021a640e00fde9ad6894c5063afcf9a37f65659 (diff)
pcr/ucsniff-ace: moved from pcr/ace to avoid name collisions
Diffstat (limited to 'pcr/ucsniff-ace/PKGBUILD')
-rw-r--r--pcr/ucsniff-ace/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/pcr/ucsniff-ace/PKGBUILD b/pcr/ucsniff-ace/PKGBUILD
new file mode 100644
index 000000000..b2e68e67d
--- /dev/null
+++ b/pcr/ucsniff-ace/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Márcio Silva <coadde@hyperbola.info>
+
+pkgname='ucsniff-ace'
+pkgver='1.10'
+pkgrel=4
+pkgdesc='A simple yet powerful VoIP Corporate Directory enumeration tool that mimics the behavior of an IP Phone in order to download the name and extension entries that a given phone can display on its screen interface.'
+url='http://ucsniff.sourceforge.net/ace.html'
+license=('GPL')
+depends=('libpcap')
+arch=('i686' 'x86_64' 'armv7h')
+source=("http://downloads.sourceforge.net/ucsniff/ace-$pkgver.tar.gz")
+sha1sums=('747aee37f74e71101317809797cdaed7077dd29e')
+replaces=('ace')
+
+prepare() {
+ cd "$srcdir/ace-$pkgver"
+
+ sed -i 's#linux/if_tr.h#netinet/if_tr.h#' client.h
+ sed -i "s:gcc :gcc $CFLAGS :g" Makefile
+}
+
+build() {
+ cd "$srcdir/ace-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/ace-$pkgver"
+
+ install -Dm755 ace "$pkgdir/usr/bin/ace"
+}