summaryrefslogtreecommitdiff
path: root/pcr/xboxdrv/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-23 16:10:37 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-23 16:10:37 +0100
commitb4296b573a8a51ba20db9ed6fbfc2705e69c45ee (patch)
tree28624159ae26de4d0668022c48e9684354c35bad /pcr/xboxdrv/PKGBUILD
parent34a0799025517f28c5fe8ca04713a316a4c3ab7f (diff)
pcr/xboxdrv: updated to 0.8.8
Diffstat (limited to 'pcr/xboxdrv/PKGBUILD')
-rw-r--r--pcr/xboxdrv/PKGBUILD67
1 files changed, 41 insertions, 26 deletions
diff --git a/pcr/xboxdrv/PKGBUILD b/pcr/xboxdrv/PKGBUILD
index ddf040950..459d69d66 100644
--- a/pcr/xboxdrv/PKGBUILD
+++ b/pcr/xboxdrv/PKGBUILD
@@ -1,40 +1,55 @@
-# Maintainer (Arch): Jack Mitchell <jack@embed.me.uk>
-# Contributor (Arch): Kevin MacMartin <prurigro at gmail dot com>
+# Maintainer (AUR): Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor (AUR): Jack Mitchell <jack@embed.me.uk>
+# Contributor (AUR): Kevin MacMartin <prurigro at gmail dot com>
+
+# parabola changes and rationale:
+# no change.
pkgname=xboxdrv
-pkgver=0.8.5
-pkgrel=3
-url="http://pingus.seul.org/~grumbel/${pkgname}/"
-pkgdesc="Userspace gamepad driver for GNU/Linux"
+pkgver=0.8.8
+pkgrel=4
+pkgdesc='Userspace gamepad driver for Linux'
+url='http://pingus.seul.org/~grumbel/xboxdrv'
+arch=('i686' 'x86_64' 'armv7h')
license=('GPL3')
-arch=('i686' 'x86_64')
-depends=('libx11' 'dbus-glib' 'libusbx' 'python2')
-makedepends=('scons' 'boost' 'pkg-config' 'libx11' 'dbus-glib' 'libusb')
-backup=("etc/default/${pkgname}")
-
-source=("http://pingus.seul.org/~grumbel/${pkgname}/${pkgname}-linux-${pkgver}.tar.bz2"
- "${pkgname}.service"
- "${pkgname}.default")
-
-sha512sums=('954a3664462dfeff63a455f3dfea4bc14f8c3e07fa9b0c299bb523b4089faad7f8d634511eb66c023bd289adbbf18e96ce26cbcf5b8ffc9bb3088f1afe532601'
- 'f1094119372512b29c070949606d6ee7ebd119195a717ddac8a60a0c94016b7d82b569283f02e05ad3e5e76227e8437c7072d346b30960d1eb2a4a681894d5d3'
- '4f6e9a12b208254e19daba477dd7787147a8b2c8a83007d92f8cfce6212c21ce3306f23a2669080f0e46986ca102ab08c262b42c678caf1a891326b4e2c40b5f')
+depends=('libx11' 'dbus-glib' 'libusb' 'python2-dbus' 'systemd')
+makedepends=('scons' 'boost' 'pkg-config' 'libx11' 'python')
+backup=("etc/default/xboxdrv")
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/xboxdrv/${pkgname}/archive/v${pkgver}.tar.gz
+ xboxdrv.service
+ xboxdrv.default
+ fix-60-sec-delay.patch
+ scons-py3.patch)
+sha512sums=('3f27856da211a14e27a84fa5919da7965262adc36da16c75eed9bae891098183b5751a3e707573b4ab64e69096ea74d455e8f64827c88b38b65af94cc13b34ad'
+ 'f1a4e7b1a06e951c3a4f5bcdec5f14db542b34963950619f0d4b1ee324d64b18ca2f63642719ef65a63e424702fb0eb33e0259937906732e587b96a9582c2e6b'
+ '4f6e9a12b208254e19daba477dd7787147a8b2c8a83007d92f8cfce6212c21ce3306f23a2669080f0e46986ca102ab08c262b42c678caf1a891326b4e2c40b5f'
+ '58170b3f96f02e5ba0af5f6641482fb1c612ca70650e475d68b55c05a62ec0831033190b90e591d593fd6b25c2a155e6c4975f37eef1534245947156a5e3285f'
+ 'b3a3bbb51fa1c4ad4dd898136c3bf7c0f13193bdd07bbcb5c8243edb747c68223fe8c5bd2fd578f6c2b18844827524abb0533ce98b6e0e60fe936597cdba811d')
prepare() {
- cd ${pkgname}-linux-${pkgver}
- sed -e 's/env python$/env python2/g' -i xboxdrvctl
+ cd ${pkgname}-${pkgver}
+ sed 's|python|python2|g' -i examples/*.py
+ patch -p1 < "${srcdir}/fix-60-sec-delay.patch"
+ # activate this patch when scons gets switched back to py3
+ # patch -p1 < "${srcdir}/scons-py3.patch"
}
build() {
- cd ${pkgname}-linux-${pkgver}
- scons $MAKEFLAGS
+ cd ${pkgname}-${pkgver}
+ scons \
+ LINKFLAGS="${LDFLAGS}" \
+ CXXFLAGS="${CPPFLAGS} ${CXXFLAGS}" \
+ "${MAKEFLAGS}"
}
package() {
- install -Dm644 ${pkgname}.service "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
- install -Dm644 ${pkgname}.default "${pkgdir}/etc/default/${pkgname}"
- cd ${pkgname}-linux-${pkgver}
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ cd ${pkgname}-${pkgver}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm 644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -Dm 644 "${srcdir}/${pkgname}.default" "${pkgdir}/etc/default/${pkgname}"
+ install -Dm 644 README.md NEWS PROTOCOL -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 examples/* -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
+ install -Dm 644 data/org.seul.Xboxdrv.conf -t "${pkgdir}/etc/dbus-1/system.d"
}
# vim: ts=2 sw=2 et: