summaryrefslogtreecommitdiff
path: root/pcr/xen/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-04-03 16:12:17 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2022-04-03 16:21:37 -0400
commit848886d6e6d72d34d1b922384f64f5efe58443c3 (patch)
tree1c1a768deec03a689cd6b0e86ff63f8de70d3b2d /pcr/xen/PKGBUILD
parent7a1bb990a57534759265f37fc1c688057201ed9c (diff)
[xen]: avoid publishing 'any' docs package to 32-bit repos
Diffstat (limited to 'pcr/xen/PKGBUILD')
-rw-r--r--pcr/xen/PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/pcr/xen/PKGBUILD b/pcr/xen/PKGBUILD
index 80b0f5022..ae6e2a6c6 100644
--- a/pcr/xen/PKGBUILD
+++ b/pcr/xen/PKGBUILD
@@ -23,7 +23,7 @@ pkgbase=xen
pkgname=("xen" "xen-docs")
pkgver=4.16.0
pkgrel=3
-pkgdesc='Open-source type-1 or baremetal hypervisor'
+pkgdesc='Type-1 or bare-metal hypervisor'
arch=('x86_64')
url='https://xenproject.org/'
license=('GPL2')
@@ -53,10 +53,11 @@ validpgpkeys=('23E3222C145F4475FA8060A783FE14C957E82BD9') # Xen.org Xen tree cod
# Follow the Xen securite mailing lists, and if a patch is applicable to our package
# add the URL here.
+# Better yet, add the patch to abslibre :)
_patches=(
- "https://xenbits.xen.org/xsa/xsa393.patch"
- "https://xenbits.xen.org/xsa/xsa394.patch"
- "https://xenbits.xen.org/xsa/xsa395.patch"
+ "xsa393.patch"
+ "xsa394.patch"
+ "xsa395.patch"
)
@@ -210,7 +211,7 @@ build() {
}
package_xen() {
- pkgdesc='Open-source type-1 or baremetal hypervisor'
+ pkgdesc='Type-1 or baremetal hypervisor'
depends=(
'zlib' 'python' 'ncurses' 'openssl' 'libx11' 'libuuid.so' 'yajl' 'libaio' 'glib2' 'pkgconf'
@@ -320,7 +321,7 @@ package_xen() {
package_xen-docs() {
pkgdesc="Xen hypervisor documentation and man pages"
- arch=("any")
+ arch=("x86_64") # no reason to publish this package to 32-bit repos
cd "${pkgbase}-${pkgver}"
make "${_common_make_flags[@]}" DESTDIR="$pkgdir" install-docs
}