summaryrefslogtreecommitdiff
path: root/social/haveged/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-02-14 17:21:27 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-02-14 17:21:27 -0300
commit568929c75b5a62756a0b984709e7db8795c6bcdf (patch)
tree076a408a7442a9a08c2b19f4d3eca196bd9f1a9a /social/haveged/PKGBUILD
parent4253d9d631fb5aec2e5621169816601a727ca38f (diff)
[social] repo
Diffstat (limited to 'social/haveged/PKGBUILD')
-rw-r--r--social/haveged/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/social/haveged/PKGBUILD b/social/haveged/PKGBUILD
new file mode 100644
index 000000000..804a22199
--- /dev/null
+++ b/social/haveged/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: pootzko <pootzko@gmail.com>
+# Contributor: kfgz <kfgz@interia.pl>
+
+pkgname=haveged
+pkgver=1.0
+pkgrel=1
+pkgdesc="A simple entropy daemon."
+arch=('i686' 'x86_64')
+url="http://www.issihosts.com/haveged"
+license="GPL"
+depends=()
+source=(${url}/${pkgname}-${pkgver}.tar.gz
+ haveged)
+md5sums=('72df03658cafac35e087fb75f6d4100d'
+ '264b725be5271288b40f363d7cfc6b68')
+
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+ make DESTDIR=${pkgdir} install
+ rm -rf ${pkgdir}/etc/init.d
+ cd ${srcdir}
+ install -D -m755 haveged ${pkgdir}/etc/rc.d/haveged
+}
+
+