summaryrefslogtreecommitdiff
path: root/~emulatorman/xchat-xsys-noaudacious/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-10 20:47:17 -0200
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-03-10 20:47:17 -0200
commit2386e0d74a9406d00dbbbab84a0e97a276fcf4b7 (patch)
treeff1e9cc9ad44838587370853a8a44fd443c72d1e /~emulatorman/xchat-xsys-noaudacious/PKGBUILD
parent8de426e6cddec256ba118c96a18b6271f454cc33 (diff)
~emulatorman/xchat-xsys-noaudacious
Diffstat (limited to '~emulatorman/xchat-xsys-noaudacious/PKGBUILD')
-rw-r--r--~emulatorman/xchat-xsys-noaudacious/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/~emulatorman/xchat-xsys-noaudacious/PKGBUILD b/~emulatorman/xchat-xsys-noaudacious/PKGBUILD
new file mode 100644
index 000000000..977999a38
--- /dev/null
+++ b/~emulatorman/xchat-xsys-noaudacious/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Gökmen Görgen <gkmngrgn_gmail.com>
+# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+pkgname=xchat-xsys-noaudacious
+pkgver=2.2.0
+pkgrel=3
+pkgdesc="Sysinfo plugin without audacious for X-Chat"
+url="http://dev.gentoo.org/~chainsaw/xsys"
+depends=('xchat-libre' 'pciutils')
+arch=('i686' 'x86_64')
+source=(http://dev.gentoo.org/~chainsaw/xsys/download/xsys-$pkgver.tar.bz2 xchat-xsys-parabola.patch no-audacious.patch)
+md5sums=('d57def00f96c7389ab593c009595f6f4' '4d22883f24606dbab588d685c553e5a1' '588e5f6d9037a07385079a5cf6ee2dbe')
+license=('GPL')
+
+build() {
+ cd $srcdir/xsys-$pkgver
+ patch -p1 -i ../no-audacious.patch || return 1
+ sed -i -e "s:/usr/share/misc/:/usr/share/hwdata/:" Makefile
+ sed -i -e "s:-O2 -Wall:${CFLAGS} -Wall:" Makefile
+ sed -i -e "s:#BUTTON:BUTTON:" Makefile
+ sed -i -e "s:# FOR AUDACIOUS # ::g" Makefile
+ patch -p1 -i ../xchat-xsys-parabola.patch || return 1
+ make || return 1
+ mkdir -p $pkgdir/usr/lib/xchat/plugins
+ cp xsys-$pkgver.so $pkgdir/usr/lib/xchat/plugins
+}