summaryrefslogtreecommitdiff
path: root/~fauno/haskell-digest/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-09-26 16:47:44 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2011-09-26 16:47:44 -0300
commit9146699991b6ea418605a56676ac6ebfb4fac030 (patch)
tree0ec75dd4a68588259426a5f85b41733de0e0f1a1 /~fauno/haskell-digest/PKGBUILD
parent0d9c46d20a30e5420d558910aa18c2eb8b5cc938 (diff)
~fauno/pandoc-1.8.2.1-2
And haskell makedeps
Diffstat (limited to '~fauno/haskell-digest/PKGBUILD')
-rw-r--r--~fauno/haskell-digest/PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/~fauno/haskell-digest/PKGBUILD b/~fauno/haskell-digest/PKGBUILD
new file mode 100644
index 000000000..724a600af
--- /dev/null
+++ b/~fauno/haskell-digest/PKGBUILD
@@ -0,0 +1,46 @@
+# custom variables
+_hkgname=digest
+_licensefile=LICENSE
+
+# PKGBUILD options/directives
+pkgname=haskell-digest
+pkgver=0.0.1.0
+pkgrel=1
+pkgdesc="Various cryptographic hashes for bytestrings; CRC32 and Adler32 for now."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=("BSD3")
+arch=('i686' 'x86_64')
+makedepends=()
+depends=("ghc=7.0.3-2"
+ "sh"
+ "haskell-bytestring=0.9.1.10"
+ "zlib")
+options=('strip')
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+install="${pkgname}.install"
+sha256sums=("40319762afc05823920126f13cba02b06544ba039e08c3f63db2ed084a9a4edc")
+
+# PKGBUILD functions
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
+}