summaryrefslogtreecommitdiff
path: root/~fauno/haskell-pandoc-types/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-08-28 16:24:19 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-08-28 16:24:19 -0300
commite0acf42ad03cac39336017463fad3f5ff2d3179f (patch)
tree6ae1fb22259bf4019c40561c760948e36123c98f /~fauno/haskell-pandoc-types/PKGBUILD
parent3f64055d01d6333452df7b36a2a581aa3a6ff96f (diff)
remove fauno personal repo from abslibre
Diffstat (limited to '~fauno/haskell-pandoc-types/PKGBUILD')
-rw-r--r--~fauno/haskell-pandoc-types/PKGBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/~fauno/haskell-pandoc-types/PKGBUILD b/~fauno/haskell-pandoc-types/PKGBUILD
deleted file mode 100644
index 954514ebe..000000000
--- a/~fauno/haskell-pandoc-types/PKGBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# custom variables
-_hkgname=pandoc-types
-_licensefile=COPYING
-
-# PKGBUILD options/directives
-pkgname=haskell-pandoc-types
-pkgver=1.8.2
-pkgrel=1
-pkgdesc="Types for representing a structured document"
-url="http://johnmacfarlane.net/pandoc"
-license=("GPL")
-arch=('i686' 'x86_64')
-makedepends=()
-depends=("ghc=7.0.3-2"
- "sh"
- "haskell-containers=0.4.0.0"
- "haskell-syb=0.3")
-options=('strip')
-source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-install="${pkgname}.install"
-sha256sums=("6a580be1ec25a747db2ee9df1c98b1f3a778493b98e5148bf8ce5ed1289e9013")
-
-# PKGBUILD functions
-build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
-
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
- --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
-}
-
-package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
-}