summaryrefslogtreecommitdiff
path: root/~fauno/pandoc/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-08-20 02:12:14 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-08-20 02:12:14 -0300
commit6a9ea931e737d49d893e0c4fc4c756f81fd52dd8 (patch)
treea9573026f80e4df99499ddbdf1fb9b2aaa8972fe /~fauno/pandoc/PKGBUILD
parent7aa631cb211cb14f96ec842b62eced0a1a14a372 (diff)
Fixed citeproc hanging and missing fontenc on texlive-libre
Diffstat (limited to '~fauno/pandoc/PKGBUILD')
-rw-r--r--~fauno/pandoc/PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/~fauno/pandoc/PKGBUILD b/~fauno/pandoc/PKGBUILD
index 410a3dd2b..3d7d1fa9f 100644
--- a/~fauno/pandoc/PKGBUILD
+++ b/~fauno/pandoc/PKGBUILD
@@ -5,15 +5,19 @@
pkgname=pandoc
pkgver=1.9.4.2
-pkgrel=1
+pkgrel=2
pkgdesc='Conversion between markup formats (no Haskell libs)'
url='http://johnmacfarlane.net/pandoc/'
license=('GPL')
arch=('i686' 'x86_64')
makedepends=('ghc' 'sh' 'cabal-install')
-options=('strip')
-source=(https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-${pkgrel}-any.src.tar.xz{,.sig} SRCBUILD)
+options=(strip !makeflags !distcc)
+source=(https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-$pkgrel-any.src.tar.xz{,.sig} SRCBUILD)
conflicts=('haskell-pandoc')
+optdepends=('texlive-most: for pdf creation')
+md5sums=('15f522c6bd0e26c709579b0a0fcfdcea'
+ 'e86da5aad2a7dfc6d53d2a2a0c562baa'
+ '415bbf263863c5cbc7c672ec1f497893')
# PKGBUILD functions
build() {
@@ -24,7 +28,7 @@ build() {
pushd ${srcdir}/${pkgname}-${pkgver}/${_hkpkg}
HOME=${srcdir}/${pkgname}-${pkgver} \
- cabal install --prefix=${srcdir}/build/usr
+ cabal install --flags="embed_data_files" --prefix=${srcdir}/build/usr
popd
done
@@ -32,7 +36,7 @@ build() {
cd ${srcdir}/${pkgname}-${pkgver}/${pkgname}-${pkgver}
HOME=${srcdir}/${pkgname}-${pkgver} \
- cabal configure --prefix=/usr --libdir=${srcdir}/build/usr/lib --flags="-library"
+ cabal configure --prefix=/usr --libdir=${srcdir}/build/usr/lib --flags="-library embed_data_files"
HOME=${srcdir}/${pkgname}-${pkgver} \
cabal build
@@ -44,6 +48,10 @@ package() {
runghc Setup.hs copy --destdir=${pkgdir}/
+# EC is unfree and makes Parabola TeXLive cry
+# besides, it's unneeded
+ sed "/fontenc/d" -i ${pkgdir}/usr/share/${pkgname}-${pkgver}/templates/default.latex
+
# runghc Setup.hs configure --prefix=DIR --bindir=DIR --libdir=DIR \
# --datadir=DIR --libsubdir=DIR --datasubdir=DIR --docdir=DIR \
# --htmldir=DIR --program-prefix=PREFIX --program-suffix=SUFFIX \
@@ -57,6 +65,3 @@ package() {
find ${pkgdir}/usr/share -type f -exec chmod 644 {} \;
find ${pkgdir}/usr/share -type d -exec chmod 755 {} \;
}
-md5sums=('3a9191e729a4547370f756ba831cad77'
- 'a8da851ee560ce54c7c5044dfb5042f0'
- '8dab4575128cf33941a577bfb500c417')