summaryrefslogtreecommitdiff
path: root/~lukeshu/dasm/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2011-12-11 18:49:46 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2011-12-11 18:49:46 -0500
commit5c561163133e61dc311355389556e2b2d0664c13 (patch)
treeb90c180384d4b7e3143445327e3f62d76b11d6f2 /~lukeshu/dasm/PKGBUILD
parent00d7d1f1b8496cfe48fa7c41070309304b1ae75d (diff)
mv ./~aur/* ./~lukeshu
Diffstat (limited to '~lukeshu/dasm/PKGBUILD')
-rw-r--r--~lukeshu/dasm/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/~lukeshu/dasm/PKGBUILD b/~lukeshu/dasm/PKGBUILD
new file mode 100644
index 000000000..79a7264b4
--- /dev/null
+++ b/~lukeshu/dasm/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Max Pray a.k.a. Synthead <synthead@gmail.com>
+
+pkgname=dasm
+pkgver=2.20.11
+pkgrel=3
+pkgdesc="An assembler for the 6502, 68HC11, 68705, 6803, HD6303, F8 and 6507 microprocessors"
+arch=('i686' 'x86_64')
+url="http://www.atari2600.org/DASM"
+license=('GPL')
+source=("http://downloads.sourceforge.net/project/$pkgname-dillon/$pkgname-dillon/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('3e67f7b8ac80419d53cc0aaa9a47ab37')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/bin/dasm" "$pkgdir/usr/bin/dasm"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/bin/ftohex" "$pkgdir/usr/bin/ftohex"
+
+ for doc in AUTHORS ChangeLog COPYING CREDITS FUTURE NEWS README README.ANDREW "doc/dasm.txt" "doc/ftohex.txt"; do
+ install -Dm 644 "$srcdir/$pkgname-$pkgver/$doc" "$pkgdir/usr/share/doc/dasm/${doc/*\/}"
+ done
+
+ mkdir -p "$pkgdir/usr/share/dasm"
+ cp -R "$srcdir/$pkgname-$pkgver"/{machines,test} "$pkgdir/usr/share/dasm"
+
+ chmod 755 "$pkgdir/usr/share"/{dasm,dasm/machines,dasm/machines/atari2600,dasm/machines/channel-f,dasm/test}
+ chmod 644 "$pkgdir/usr/share/dasm"/{machines/atari2600,machines/channel-f,test}/*
+}