summaryrefslogtreecommitdiff
path: root/~lukeshu/esmtp/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-11-21 12:41:48 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2017-11-21 12:41:48 -0500
commite7b9652fefca226359a6280ac2d85acf89f066e6 (patch)
tree1f5ef38b322a58fb1c5a296ca42f5c36386b983c /~lukeshu/esmtp/PKGBUILD
parent72c22f53c3c87c53fe48e2b879f8b2ed84f8c694 (diff)
add ~lukeshu/esmtp
Diffstat (limited to '~lukeshu/esmtp/PKGBUILD')
-rw-r--r--~lukeshu/esmtp/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/~lukeshu/esmtp/PKGBUILD b/~lukeshu/esmtp/PKGBUILD
new file mode 100644
index 000000000..e814a89fc
--- /dev/null
+++ b/~lukeshu/esmtp/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Loui Chang <louipc dot ist at gmail company>
+# Contributor: Jeff Mickey <j@codemac.net>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+
+_pkgname=esmtp
+pkgver=1.2
+pkgname=$_pkgname-lukeshu
+provides=($_pkgname=$pkgver)
+conflicts=($_pkgname)
+pkgrel=6
+pkgdesc="An easy SMTP forwarder."
+arch=('i686' 'x86_64')
+url='http://esmtp.sourceforge.net'
+url='https://git.lukeshu.com/esmtp/'
+license=('GPL')
+depends=('libesmtp-lukeshu' 'openssl')
+optdepends=('liblockfile: for esmtp-wrapper script'
+ 'procmail: for local mail delivery')
+provides=('smtp-forwarder')
+conflicts=('smtp-forwarder')
+source=("http://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2"
+ "0001-Produce-more-useful-Invalid-peer-certificate-error-m.patch")
+md5sums=('79a9c1f9023d53f35bb82bf446150a72'
+ '799571f0b37f85f60928e32e03afdf51')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ patch -Np1 -i ../0001-Produce-more-useful-Invalid-peer-certificate-error-m.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm0644 README "${pkgdir}/usr/share/doc/esmtp/README"
+ install -Dm0644 sample.esmtprc "${pkgdir}/usr/share/doc/esmtp/sample.esmtprc"
+ install -Dm0755 esmtp-wrapper "${pkgdir}/usr/share/esmtp/esmtp-wrapper"
+ install -Dm0755 ylwrap "${pkgdir}/usr/share/esmtp/ylwrap"
+}