summaryrefslogtreecommitdiff
path: root/cross/xtensa-unknown-elf-binutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/xtensa-unknown-elf-binutils/PKGBUILD')
-rw-r--r--cross/xtensa-unknown-elf-binutils/PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/cross/xtensa-unknown-elf-binutils/PKGBUILD b/cross/xtensa-unknown-elf-binutils/PKGBUILD
index deb8d4b0e..072e5e50d 100644
--- a/cross/xtensa-unknown-elf-binutils/PKGBUILD
+++ b/cross/xtensa-unknown-elf-binutils/PKGBUILD
@@ -6,9 +6,9 @@
_pkgname=binutils
_target="xtensa-unknown-elf"
-pkgname=${_target}-binutils
+pkgname=${_target}-${_pkgname}
pkgver=2.23.2
-pkgrel=2.4
+pkgrel=2.5
pkgdesc="A set of programs to assemble and manipulate binary and object files for the Xtensa architecture"
arch=('i686' 'x86_64' 'mips64el')
url="http://www.gnu.org/software/binutils/"
@@ -18,9 +18,11 @@ depends=('glibc>=2.17' 'zlib')
options=('!libtool' '!distcc' '!ccache')
install=${_target}-binutils.install
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2{,.sig}
+ https://raw.github.com/qca/open-ath9k-htc-firmware/1.3.2/local/patches/binutils.patch
binutils-2.23.2-texinfo-5.0.patch)
md5sums=('4f8fa651e35ef262edc01d60fb45702e'
'dfde4428f08d91f309cdcfe92bf28d08'
+ '7077126d96e9a755a0eaddb5505efe68'
'34e439ce23213a91e2af872dfbb5094c')
prepare() {
@@ -30,6 +32,9 @@ prepare() {
# http://sourceware.org/git/?p=binutils.git;a=patch;h=935f8542
patch -p1 -i ${srcdir}/binutils-2.23.2-texinfo-5.0.patch
+ # open-ath9k-htc-firmware patch
+ patch -p1 -i ${srcdir}/binutils.patch
+
# hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure