summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-knock/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-knock/PKGBUILD')
-rw-r--r--kernels/linux-libre-knock/PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/kernels/linux-libre-knock/PKGBUILD b/kernels/linux-libre-knock/PKGBUILD
index 262446e8d..81eeed246 100644
--- a/kernels/linux-libre-knock/PKGBUILD
+++ b/kernels/linux-libre-knock/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer (Arch): Thomas Baechler <thomas@archlinux.org>
+# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
+# Contributor (Arch): Thomas Baechler <thomas@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
# Contributor: Sorin-Mihai Vârgolici <smv@yobicore.org>
@@ -19,7 +19,7 @@ _replacesoldmodules=() # '%' gets replaced with _kernelname
_srcname=linux-${_pkgbasever%-*}
_archpkgver=${_pkgver%-*}
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://gnunet.org/knock"
license=('GPL2')
@@ -45,6 +45,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'linux.preset'
'0001-block-loop-convert-to-per-device-workqueue.patch'
'0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch'
+ '0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch'
+ 'bitmap-enable-booting-for-dm-md-raid1.patch'
'change-default-console-loglevel.patch')
sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'SKIP'
@@ -63,6 +65,8 @@ sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'9e1d3fd95d768a46353593f6678513839cedb98ee66e83d9323233104ec3b23f'
'bbe3631c737ed8329a1b7a9610cc0a07330c14194da5e9afec7705e7f37eeb81'
+ '08f69d122021e1d13c31e5987c23021916a819846c47247b3f1cee2ef99d7f82'
+ '959c4d71b5dc50434eeecf3a8608758f57f111c6e999289c435b13fc8c6be5f0'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
@@ -103,6 +107,15 @@ prepare() {
patch -Np1 -i ../0001-block-loop-convert-to-per-device-workqueue.patch
patch -Np1 -i ../0002-block-loop-avoiding-too-many-pending-per-work-I-O.patch
+ # Fix bluetooth chip initialization on some macbooks (FS#45554)
+ # http://marc.info/?l=linux-bluetooth&m=143690738728402&w=2
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100651
+ patch -Np1 -i ../0001-Bluetooth-btbcm-allow-btbcm_read_verbose_config-to-f.patch
+
+ # Fix kernel oops when booting with root on RAID1 LVM (FS#45548)
+ # https://bugzilla.kernel.org/show_bug.cgi?id=100491#c24
+ patch -Np1 -i ../bitmap-enable-booting-for-dm-md-raid1.patch
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)