summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-knock/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-knock/PKGBUILD')
-rw-r--r--kernels/linux-libre-knock/PKGBUILD27
1 files changed, 25 insertions, 2 deletions
diff --git a/kernels/linux-libre-knock/PKGBUILD b/kernels/linux-libre-knock/PKGBUILD
index 0b451888b..64ec61576 100644
--- a/kernels/linux-libre-knock/PKGBUILD
+++ b/kernels/linux-libre-knock/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 203405 2014-01-10 08:45:42Z tpowa $
+# $Id: PKGBUILD 203524 2014-01-12 13:05:55Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -13,7 +13,7 @@ _basekernel=3.12
_sublevel=7
_knockpatchver=${_basekernel}.4
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
+pkgrel=2
_lxopkgver=${_basekernel}.7 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -32,6 +32,12 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
+ 'sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch'
+ 'sunrpc-replace-gssd_running-with-more-reliable-check.patch'
+ 'nfs-check-gssd-running-before-krb5i-auth.patch'
+ 'rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch'
+ 'sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch'
+ 'rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('254f59707b6676b59ce5ca5c3c698319'
'c42ff446236915fe1a6e2b6f9724d267'
@@ -44,6 +50,12 @@ md5sums=('254f59707b6676b59ce5ca5c3c698319'
'44260d2cb1a8b51c119d2ce1f83e457a'
'98beb36f9b8cf16e58de2483ea9985e3'
'd50c1ac47394e9aec637002ef3392bd1'
+ 'd4a75f77e6bd5d700dcd534cd5f0dfce'
+ 'dc86fdc37615c97f03c1e0c31b7b833a'
+ '88eef9d3b5012ef7e82af1af8cc4e517'
+ 'cec0bb8981936eab2943b2009b7a6fff'
+ '88d9cddf9e0050a76ec4674f264fb2a1'
+ 'cb9016630212ef07b168892fbcfd4e5d'
'7554da820df91c282656972976d9e0b5')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
@@ -79,6 +91,17 @@ prepare() {
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
+ # fix 15 seocnds nfs delay
+ patch -Np1 -i "${srcdir}/sunrpc-create-a-new-dummy-pipe-for-gssd-to-hold-open.patch"
+ patch -Np1 -i "${srcdir}/sunrpc-replace-gssd_running-with-more-reliable-check.patch"
+ patch -Np1 -i "${srcdir}/nfs-check-gssd-running-before-krb5i-auth.patch"
+ # fix nfs kernel oops
+ # #37866
+ patch -Np1 -i "${srcdir}/rpc_pipe-remove-the-clntXX-dir-if-creating-the-pipe-fails.patch"
+ patch -Np1 -i "${srcdir}/sunrpc-add-an-info-file-for-the-dummy-gssd-pipe.patch"
+
+ patch -Np1 -i "${srcdir}/rpc_pipe-fix-cleanup-of-dummy-gssd-directory-when-notification-fails.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-knock|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \