summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index 9f8bda31f..91832cc42 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 192042 2013-08-05 08:13:15Z tpowa $
+# $Id: PKGBUILD 192495 2013-08-13 09:26:23Z tpowa $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
@@ -6,8 +6,8 @@
pkgbase=linux-libre-pae # Build stock -LIBRE-PAE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.10
-pkgver=${_basekernel}.5
-pkgrel=1
+pkgver=${_basekernel}.6
+pkgrel=2
arch=('i686')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -20,13 +20,19 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
'boot-logo.patch'
- 'change-default-console-loglevel.patch')
+ 'change-default-console-loglevel.patch'
+ 'criu-no-expert.patch'
+ '3.10.6-logitech-dj.patch'
+ '3.10.6-reset-superseed-xhci-hcd.patch')
md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
'f4810ea4bd977321d76edcde8dc756c9'
- '25d73446f6071d0d1482822ae0072203'
+ '7dc48829b6bcb5db3779d558c705ab63'
'f302c931bd85309da9d9792b4cc96467'
'04b21c79df0a952c22d681dd4f4562df'
- 'f3def2cefdcbb954c21d8505d23cc83c')
+ 'f3def2cefdcbb954c21d8505d23cc83c'
+ 'd50c1ac47394e9aec637002ef3392bd1'
+ '3ff40ca684cfe719723e627e2cef7cea'
+ 'e751378a3e94532bfe85fb82c80e26c0')
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE-PAE
@@ -46,6 +52,16 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # allow criu without expert option set
+ # patch from fedora
+ patch -Np1 -i "${srcdir}/criu-no-expert.patch"
+
+ # fix https://bugs.archlinux.org/task/35991 - [linux] 3.10.x renders Logitech Unified Receivers useless
+ patch -Np1 -i "${srcdir}/3.10.6-logitech-dj.patch"
+
+ # fix https://bugs.archlinux.org/task/36296 - [linux] 3.10.3 reset SuperSpeed USB using xhci_hcd
+ patch -Np1 -i "${srcdir}/3.10.6-reset-superseed-xhci-hcd.patch"
+
cat "${srcdir}/config" > ./.config # simpler
if [ "${_kernelname}" != "" ]; then