summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-rt/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-rt/PKGBUILD')
-rw-r--r--kernels/linux-libre-rt/PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/kernels/linux-libre-rt/PKGBUILD b/kernels/linux-libre-rt/PKGBUILD
index 1b18356e4..36287b9fb 100644
--- a/kernels/linux-libre-rt/PKGBUILD
+++ b/kernels/linux-libre-rt/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: timbosa <tinny_tim@dodo.com.au>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
-# Contributor (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
-# Contributor (Parabola): Jorge Lopez <jorginho@adinet.com.uy>
-# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Maintainer (Parabola): Jorge Lopez <jorginho@adinet.com.uy>
+# Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
# Contributor (Parabola): Márcio Silva <coadde@adinet.com.uy>
pkgbase=linux-libre-rt
@@ -13,8 +13,8 @@ pkgname=('linux-libre-rt' 'linux-libre-rt-headers') # Build stock -LIBRE kernel
# pkgname=linux-custom # Build kernel with a different name
_kernelname=-LIBRE-RT
_basekernel=3.2
-_releasever=11
-_rtpatchver=rt20
+_releasever=12
+_rtpatchver=rt22
_pkgver=${_basekernel}.${_releasever}
pkgver=${_basekernel}.${_releasever}_${_rtpatchver}
pkgrel=1
@@ -23,8 +23,8 @@ url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
-source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-libre/linux-${_basekernel}-libre.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}-libre/patch-${_basekernel}-libre-${_pkgver}-libre.xz"
+source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
+ "http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgver}-gnu/patch-${_basekernel}-gnu-${_pkgver}-gnu.xz"
"http://www.kernel.org/pub/linux/kernel/projects/rt/3.2/patch-${_pkgver}-${_rtpatchver}.patch.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
@@ -35,9 +35,9 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-li
'i915-fix-ghost-tv-output.patch'
'i915-gpu-finish.patch'
'ext4-options.patch')
-md5sums=('27c641c4f6785fc647cdd3e44963a55c'
- '09abd6a4e9ae7373a3151b61781ab2fe'
- 'b469c9b82f05abe5491154ea18aa06c9'
+md5sums=('65c669b6e4888db84a80882461851867'
+ 'd1d6c566dbc5b9fe6983eb6cab8fa00a'
+ 'd530078f8e59eda4de457041687db952'
'6141ab0cb60a5cf9e6ee3bdf8c8c79b1'
'c2f3423d7c7d8e5776e961b75a52a3fc'
'0d001b0277f318bc40a263aaa980d44e'
@@ -50,7 +50,9 @@ md5sums=('27c641c4f6785fc647cdd3e44963a55c'
build() {
cd "${srcdir}/linux-${_basekernel}"
- patch -Np1 -i "${srcdir}/patch-${_basekernel}-libre-${_pkgver}-libre"
+ if [ "${_basekernel}" != "${pkgver}" ]; then
+ patch -Np1 -i "${srcdir}/patch-${_basekernel}-gnu-${_pkgver}-gnu"
+ fi
# add realtime patch
patch -Np1 -i "${srcdir}/patch-${_pkgver}-${_rtpatchver}.patch"
@@ -90,7 +92,6 @@ build() {
sed -ri "s|^(EXTRAVERSION =).*|\1 -${pkgrel}|" Makefile
# get kernel version
- rm localversion-rt
make prepare
# load configuration
@@ -108,7 +109,7 @@ build() {
#return 1
####################
- yes "" | make
+ yes "" | make config
# build!
make ${MAKEFLAGS} bzImage modules