summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-xen/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-xen/PKGBUILD')
-rw-r--r--kernels/linux-libre-xen/PKGBUILD31
1 files changed, 14 insertions, 17 deletions
diff --git a/kernels/linux-libre-xen/PKGBUILD b/kernels/linux-libre-xen/PKGBUILD
index 8c3d6c88d..b1aa76d3a 100644
--- a/kernels/linux-libre-xen/PKGBUILD
+++ b/kernels/linux-libre-xen/PKGBUILD
@@ -1,12 +1,13 @@
-# $Id: PKGBUILD 196455 2013-10-14 06:53:31Z tpowa $
+# $Id: PKGBUILD 199009 2013-11-06 08:26:56Z tpowa $
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
pkgbase=linux-libre-xen # Build stock -LIBRE-XEN kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.11
-pkgver=${_basekernel}.5
+_basekernel=3.12
+#pkgver=${_basekernel}.5
+pkgver=${_basekernel}
pkgrel=1
arch=('i686')
url="http://linux-libre.fsfla.org/"
@@ -14,23 +15,21 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
'boot-logo.patch'
'change-default-console-loglevel.patch'
- 'criu-no-expert.patch'
- '3.11-haswell-intel_pstate.patch')
-md5sums=('7ec84223c7adcf01a5287eb7af96b7e7'
- 'bcd700aa1ae7f13107a14885923358eb'
- 'e97b1c54a6ebeb8647b49a4abda64072'
+ 'criu-no-expert.patch')
+md5sums=('254f59707b6676b59ce5ca5c3c698319'
+ #'bcd700aa1ae7f13107a14885923358eb'
+ 'fc7677b76dbe202a202100c027828d6b'
'b7c2805bb287a644c0a303bf7721e534'
- '36e90334b12b2e9d53fd92129ee98f5b'
+ '44260d2cb1a8b51c119d2ce1f83e457a'
'98beb36f9b8cf16e58de2483ea9985e3'
- 'd50c1ac47394e9aec637002ef3392bd1'
- '1040ae6c10d4a68f89899f94a2318a17')
+ 'd50c1ac47394e9aec637002ef3392bd1')
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE-XEN
@@ -45,16 +44,14 @@ prepare() {
# add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"
+ # fix issue on Hal8188EFWImg_CE.c deblobbed file
+ sed -i "\|DEBLOBBED| s|,||" drivers/staging/rtl8188eu/hal/Hal8188EFWImg_CE.c
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
- # add intel haswell support to intel_pstate
- # https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/patch/?id=6cdcdb793791f776ea9408581b1242b636d43b37
- # will be in 3.12
- patch -Np1 -i "${srcdir}/3.11-haswell-intel_pstate.patch"
-
# allow criu without expert option set
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"