summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-xen/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'kernels/linux-libre-xen/PKGBUILD')
-rw-r--r--kernels/linux-libre-xen/PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/kernels/linux-libre-xen/PKGBUILD b/kernels/linux-libre-xen/PKGBUILD
index 24e08b644..685710c52 100644
--- a/kernels/linux-libre-xen/PKGBUILD
+++ b/kernels/linux-libre-xen/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Si Feng <sci.feng at gmail.com>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
-# Contributor (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
-# Contributor (Parabola): Sorin-Mihai Vârgolici <smv@yobicore.org>
-# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
+# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Maintainer (Parabola): Sorin-Mihai Vârgolici <smv@yobicore.org>
+# Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
# Contributor (Parabola): Márcio Silva <coadde@adinet.com.uy>
pkgbase=linux-libre-xen
pkgname=('linux-libre-xen' 'linux-libre-xen-headers') # Build stock -LIBRE kernel with Xen guest support
# pkgname=linux-custom # Build kernel with a different name
_kernelname=-LIBRE-XEN
-_basekernel=3.2
-pkgver=${_basekernel}.11
+_basekernel=3.3
+#pkgver=${_basekernel}.11
+pkgver=${_basekernel}
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('i686')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
-source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-libre/linux-${_basekernel}-libre.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/patch-${_basekernel}-libre-${pkgver}-libre.xz"
+source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-libre/patch-${_basekernel}-libre-${pkgver}-libre.xz"
# the main kernel config files
- 'config.i686' 'config.x86_64'
+ 'config.i686'
# standard config files for mkinitcpio ramdisk
"${pkgname}.preset"
'boot-logo.patch'
@@ -29,10 +30,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-li
'i915-fix-ghost-tv-output.patch'
'i915-gpu-finish.patch'
'ext4-options.patch')
-md5sums=('27c641c4f6785fc647cdd3e44963a55c'
- '09abd6a4e9ae7373a3151b61781ab2fe'
- 'aafbddba8ddeca5f13bac26cd5167a6c'
- '81dce3388fcb0b1e8aa1070ccbfb5d62'
+md5sums=('5487da14ca81715a469c7594d39722fa'
+ '1f29ffc2b18d7c37c781d7938ada59ab'
'b7c2805bb287a644c0a303bf7721e534'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
@@ -43,7 +42,7 @@ md5sums=('27c641c4f6785fc647cdd3e44963a55c'
build() {
cd "${srcdir}/linux-${_basekernel}"
- patch -Np1 -i "${srcdir}/patch-${_basekernel}-libre-${pkgver}-libre"
+# patch -Np1 -i "${srcdir}/patch-${_basekernel}-libre-${pkgver}-libre"
# Add freedo as boot logo
patch -Np1 -i "${srcdir}/boot-logo.patch"