summaryrefslogtreecommitdiff
path: root/libre-testing/file/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/file/PKGBUILD')
-rw-r--r--libre-testing/file/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/libre-testing/file/PKGBUILD b/libre-testing/file/PKGBUILD
new file mode 100644
index 000000000..7a0a5f590
--- /dev/null
+++ b/libre-testing/file/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=file
+pkgver=5.34
+pkgrel=1
+pkgdesc='File type identification utility'
+arch=(x86_64 ppc64le)
+license=('custom')
+groups=('base' 'base-devel')
+url='https://www.darwinsys.com/file/'
+depends=('glibc' 'zlib')
+source=("ftp://ftp.astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
+validpgpkeys=('BE04995BA8F90ED0C0C176C471112AB16CB33B3A') # Christos Zoulas
+md5sums=('44b0b6983462b18f96403d4d3ad80254'
+ 'SKIP')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ # seccomp breaks file -z foo.xz
+ # does a whole pipe-fork-exec dance with /bin/xz, so difficult to fix
+ # this breaks makepkg, specifically on the linux PKGBUILD's patch-*.xz
+
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share/file \
+ --enable-fsect-man5 \
+ --disable-libseccomp
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: