summaryrefslogtreecommitdiff
path: root/libre-testing/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/iceweasel/PKGBUILD')
-rw-r--r--libre-testing/iceweasel/PKGBUILD34
1 files changed, 28 insertions, 6 deletions
diff --git a/libre-testing/iceweasel/PKGBUILD b/libre-testing/iceweasel/PKGBUILD
index b9de99364..ade199152 100644
--- a/libre-testing/iceweasel/PKGBUILD
+++ b/libre-testing/iceweasel/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
@@ -28,7 +27,7 @@
_pkgname=firefox
pkgname=iceweasel
epoch=1
-pkgver=61.0.1
+pkgver=61.0.2
pkgrel=0.testing1
_bver=61.0
_brel=1
@@ -39,7 +38,7 @@ license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
-depends+=('icu>=61' 'icu<62')
+depends+=('icu>=62' 'icu<63')
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
autoconf2.13 rust mercurial clang llvm jack gtk2 python)
makedepends+=(mozilla-searchplugins quilt libxslt imagemagick)
@@ -50,11 +49,12 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip)
replaces=("$_pkgname")
conflicts=("$_pkgname")
+# https://archive.mozilla.org/pub/firefox/releases/$pkgver/SOURCE
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
libre.patch)
-sha256sums=('708f4dc39fdf105fe9d3ee6b52412a1c7548fd7d34e14c29f840064de3fe8a28'
+sha256sums=('0bdecbbb2a955c9f4c5cd0b33acd1e47afcb6cd57ac89cf11257668e3cef202c'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
'dabd5a0b8023e8ca13f6ae5fcb9e6c29531fc952bc781b4aa25c8a598187768e'
'SKIP'
@@ -62,8 +62,14 @@ sha256sums=('708f4dc39fdf105fe9d3ee6b52412a1c7548fd7d34e14c29f840064de3fe8a28'
validpgpkeys=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
prepare() {
+ mkdir path
+ ln -s /usr/bin/python2 path/python
+
cd firefox-$pkgver
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
+ patch -Np1 -i ../no-crmf.diff
+
cat >.mozconfig <<END
ac_add_options --enable-application=browser
@@ -88,6 +94,7 @@ ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
+ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -97,6 +104,7 @@ ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
+ac_add_options --disable-stylo
ac_add_options --disable-eme
END
@@ -149,8 +157,9 @@ END
\|installLinux| s|true|false|
' browser/base/content/browser-plugins.js
- # replace newtab page with abouthome
- #cat browser/base/content/abouthome/aboutHome.xhtml > browser/base/content/newtab/newTab.xhtml
+ # re-use 'abouthome' page for 'newtab' page
+ install -d browser/base/content/newtab
+ cat browser/base/content/abouthome/aboutHome.xhtml > browser/base/content/newtab/newTab.xhtml
# Load our searchplugins
rm -rv browser/locales/searchplugins
@@ -166,8 +175,16 @@ END
build() {
cd firefox-$pkgver
+ # _FORTIFY_SOURCE causes configure failures
+# CPPFLAGS+=" -O2"
+
+ export PATH="$srcdir/path:$PATH"
export MOZ_SOURCE_REPO="$_repo"
+ # Do PGO
+ #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
+ # MOZ_PGO=1 ./mach build
+
./mach build
./mach buildsymbols
}
@@ -520,6 +537,11 @@ END
install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/$pkgname.desktop"
+ # Use system-provided dictionaries
+ rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
+
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh