summaryrefslogtreecommitdiff
path: root/libre-testing/m4/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/m4/PKGBUILD')
-rw-r--r--libre-testing/m4/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/libre-testing/m4/PKGBUILD b/libre-testing/m4/PKGBUILD
new file mode 100644
index 000000000..deb3f64a5
--- /dev/null
+++ b/libre-testing/m4/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=m4
+pkgver=1.4.18
+pkgrel=1
+pkgdesc="The GNU macro processor"
+arch=('x86_64' 'ppc64le')
+url="http://www.gnu.org/software/m4"
+license=('GPL3')
+groups=('base-devel')
+depends=('glibc' 'bash')
+source=(ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.xz{,.sig})
+md5sums=('730bb15d96fffe47e148d1e09235af82'
+ 'SKIP')
+validpgpkeys=('71C2CC22B1C4602927D2F3AAA7A16B4A2527436A') # Eric Blake
+
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make prefix=${pkgdir}/usr install
+}