summaryrefslogtreecommitdiff
path: root/libre-testing/ruby-rdiscount/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/ruby-rdiscount/PKGBUILD')
-rw-r--r--libre-testing/ruby-rdiscount/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/libre-testing/ruby-rdiscount/PKGBUILD b/libre-testing/ruby-rdiscount/PKGBUILD
new file mode 100644
index 000000000..76e4b58bd
--- /dev/null
+++ b/libre-testing/ruby-rdiscount/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net
+# Maintainer (AUR): Alexsandr Pavlov <kidoz at mail dot ru>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo at gmail dot com>
+
+_gemname=rdiscount
+pkgname=ruby-$_gemname
+pkgver=1.6.5
+pkgdesc="C implementation of John Gruber's Markdown."
+url="http://dafoster.net/projects/rdiscount/"
+
+# About the license: It is a 4-clause BSD license with the 3rd clause modified
+# to mention documentation instead of advertising. Not to be confused with
+# "Modified BSD", which the FSF uses to refer to a 3-clause BSD license
+# (dropping the 3rd clause). Because of the way it is modified, it doesn't have
+# the problems normally associated with the 4-clause BSD license.
+license=('custom:modified-BSD4')
+
+pkgrel=2
+arch=('i686' 'x86_64')
+depends=('ruby')
+makedepends=('rubygems')
+source=(http://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+md5sums=('2de321f1ba826f80b84fe45c0d013fcf')
+
+package() {
+ cd "${srcdir}"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
+ "$_gemname-$pkgver.gem"
+
+ install -Dm644 "$pkgdir$_gemdir"/gems/$_gemname-$pkgver/COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ shopt -s nullglob
+ for file in "$pkgdir$_gemdir"/gems/$_gemname-$pkgver/man/*.{1..8}; do
+ install -Dm644 "$file" "$pkgdir"/usr/share/man/man${file##*.}/${file##*/}
+ done
+}