summaryrefslogtreecommitdiff
path: root/libre-testing/your-system-sanity/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/your-system-sanity/PKGBUILD')
-rw-r--r--libre-testing/your-system-sanity/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/libre-testing/your-system-sanity/PKGBUILD b/libre-testing/your-system-sanity/PKGBUILD
index 9aca42d2d..0020c5ce2 100644
--- a/libre-testing/your-system-sanity/PKGBUILD
+++ b/libre-testing/your-system-sanity/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: Parabola Project <dev@lists.parabola.nu>
+# SPDX-License-Identifier: CC0-1.0
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
pkgname=your-system-sanity
-pkgdesc="This package Warns about and fails to install/upgrade any offending Third Party Package Manager."
-license=('GPL3')
-url="https://git.parabola.nu/abslibre.git"
pkgver=0.2
pkgrel=2
-
-arch=('any')
-depends=('pacman')
-groups=('base' 'base-openrc')
+pkgdesc="This package Warns about and fails to install/upgrade any offending Third Party Package Manager."
+arch=(any)
+url=https://labs.parabola.nu/issues/1035 # TODO: add wiki article for 'url'
+license=(GPL3)
source=('TPPM.hook' 'TPPMwarn')
+
sha512sums=('452022078de19bc9353ee3f0a2bfca2142c56b99d21276ae4de00568dbf77e3701bd4edd6e70f7454b35602712d601ce08542afcce7a86370399318d09aa74ba'
'cc30673b8bdf63c8de6cb0cdd4397f93f3c855a051ce194cb3d2459f83728d8749b661dfab33ae961b64ba6ec4809946421806c596e459101f1da28d2fec6876')
-package() {
- cd "$srcdir"
- install -Dm755 TPPMwarn "$pkgdir"/usr/bin/TPPMwarn
- install -Dm644 TPPM.hook "$pkgdir"/etc/pacman.d/hooks/TPPM.hook
+package()
+{
+ install -Dm755 TPPMwarn "${pkgdir}"/usr/bin/TPPMwarn
+ install -Dm644 TPPM.hook "${pkgdir}"/etc/pacman.d/hooks/TPPM.hook
}