summaryrefslogtreecommitdiff
path: root/libre/acpi_call-dkms/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/acpi_call-dkms/PKGBUILD')
-rw-r--r--libre/acpi_call-dkms/PKGBUILD80
1 files changed, 44 insertions, 36 deletions
diff --git a/libre/acpi_call-dkms/PKGBUILD b/libre/acpi_call-dkms/PKGBUILD
index 101fc0fc9..814955791 100644
--- a/libre/acpi_call-dkms/PKGBUILD
+++ b/libre/acpi_call-dkms/PKGBUILD
@@ -1,50 +1,58 @@
-# Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
-# Contributor (Arch): mortzu <me@mortzu.de>
-# Contributor (Arch): fnord0 <fnord0@riseup.net>
-# Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
-# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
+# Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: mortzu <me@mortzu.de>
+# Contributor: fnord0 <fnord0@riseup.net>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.8.3
+# parabola changes and rationale:
+# - no significant change - re-package for linux-libre
+# - pin to kernel versions
+
+
+# build order:
+# acpi_call-dkms <- acpi_call-lts
+# acpi_call
+# linux-libre-lts-headers <- acpi_call-lts
+# tp_smapi-lts
+# linux-libre-headers <- acpi_call
+# tp_smapi
+#
+# NOTE: It is normally not necessary to edit any of these PKGBUILDs.
+# These packages may be built as a batch, with the helper script:
+# 'scripts/package-all-acpi_call-tp_smapi'
+# Simply edit 'KERNEL_VER' and/or 'KERNEL_LTS_VER' in the helper script.
+# It will build any or all of the above packages,
+# but only those for which the PKGBUILD '_basekernel' differs,
+# update '_basekernel', and commit the changes to VCS, if successful.
+
+
+_basekernel=6.7.4
pkgname=acpi_call-dkms
-pkgver=1.1.0
-pkgrel=287
+_tag='9f1c0b5d046bdfdec769809435257647fd475473' # git rev-parse v${_tag_name}
+pkgver=1.2.2
+pkgrel=1
pkgrel+=.parabola1.basekernel${_basekernel}
pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call - module sources'
-pkgdesc+=' (for linux-libre)'
-url='https://github.com/mkottman/acpi_call'
-arch=('x86_64')
-arch+=('i686')
+pkgdesc+=" (for 'linux-libre')"
+url='https://github.com/nix-community/acpi_call'
+arch=('any')
+arch=('armv7h' 'i686' 'x86_64') # just to simplify the package-all-acpi_call-tp_smapi script
license=('GPL')
depends=('dkms')
-makedepends=(linux-libre-headers=${_basekernel})
-provides=("acpi_call=$pkgver-${pkgrel%%.*}")
+makedepends=('git')
+provides=("acpi_call=${pkgver}-${pkgrel%%.*}")
conflicts=('acpi_call')
-source=("acpi_call-${pkgver}.tar.gz::https://github.com/mkottman/acpi_call/archive/v${pkgver}.tar.gz"
- '0001-linux-5.6.patch'
+source=("git+https://github.com/nix-community/acpi_call.git#tag=${_tag}"
'dkms.conf')
-sha256sums=('d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0'
- '1f397f087fd96d5286907c90f518bbe68b0d19f83ab30bb124f76a19693a932c'
- '32e6ea6523b13132c6c7838bba7fbf3d040ba2d35a892c2c356245612720df8a')
-
-prepare() {
- cd acpi_call-$pkgver
-
- # Fix build with Linux >= 5.6
- # also: Linux-libre >= 3.17-gnu (acpi.h)
- # also: Linux-libre >= 4.12-gnu (uaccess.h)
- patch -Np1 < ../0001-linux-5.6.patch
-}
+b2sums=('SKIP'
+ '504da1102e778fe54368e990408dbef02f5b2ce91f683d170f3d6a1a2f9349d00d61dcbddd0262a8dfc958ea0964135ba58d8dd88ac06bd10b5e13b90f11faef')
package() {
- cd acpi_call-$pkgver
-
- install -Dt "$pkgdir/usr/src/acpi_call-$pkgver" -m0644 Makefile acpi_call.c ../dkms.conf
-
- echo acpi_call | install -Dm0644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/acpi_call.conf"
-
- mkdir -p "$pkgdir/usr/share/acpi_call"
- cp -t "$pkgdir/usr/share/acpi_call" -dr --no-preserve=ownership examples support
+ install -D -m0644 acpi_call/{Makefile,acpi_call.c} dkms.conf -t "${pkgdir}"/usr/src/acpi_call-${pkgver}
+ echo acpi_call | install -D -m0644 /dev/stdin "${pkgdir}"/usr/lib/modules-load.d/acpi_call.conf
+ install -d -m0755 "${pkgdir}"/usr/share/acpi_call
+ cp -dr --no-preserve=ownership acpi_call/{examples,support} "${pkgdir}"/usr/share/acpi_call/
}