summaryrefslogtreecommitdiff
path: root/libre/acpi_call/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/acpi_call/PKGBUILD')
-rw-r--r--libre/acpi_call/PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/libre/acpi_call/PKGBUILD b/libre/acpi_call/PKGBUILD
index ef36595f4..468336df6 100644
--- a/libre/acpi_call/PKGBUILD
+++ b/libre/acpi_call/PKGBUILD
@@ -6,7 +6,20 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.17.3
+# build order:
+# acpi_call-dkms <- acpi_call-lts
+# acpi_call
+# linux-libre-lts-headers <- acpi_call-lts
+# tp_smapi-lts
+# linux-libre-headers <- acpi_call
+# tp_smapi
+#
+# these packages may be built as a batch, with the helper script:
+# 'scripts/package-all-acpi_call-tp_smapi'
+# simply edit '_basekernel' in each # TODO: automate that too
+
+
+_basekernel=5.18.14
pkgname=acpi_call
pkgver=1.2.2
@@ -19,7 +32,7 @@ arch=('x86_64')
arch+=('armv7h' 'i686')
license=('GPL')
makedepends=(linux-libre-headers=${_basekernel} "acpi_call-dkms=$pkgver")
-makedepends+=(gcc=11.2.0) # `dkms` requires the same compiler version which built the kernel
+#makedepends+=(gcc=11.2.0) # `dkms` requires the same compiler version which built the kernel
conflicts=('acpi_call-dkms')
build() {