summaryrefslogtreecommitdiff
path: root/libre/asciidoc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/asciidoc/PKGBUILD')
-rw-r--r--libre/asciidoc/PKGBUILD68
1 files changed, 0 insertions, 68 deletions
diff --git a/libre/asciidoc/PKGBUILD b/libre/asciidoc/PKGBUILD
deleted file mode 100644
index 9ab871269..000000000
--- a/libre/asciidoc/PKGBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Contributor (Arch): Chris Brannon <cmbrannon79@gmail.com>
-# Contributor (Arch): Geoffroy Carrier <geoffroy@archlinux.org>
-# Contributor (Arch): Dan McGee <dan@archlinux.org>
-# Contributor (Arch): Jaroslaw Rosiek <philosoph@interia.pl>
-# Contributor (Arch): Darwin Bautista <djclue917@gmail.com>
-# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
-# Maintainer (Arch): Florian Pritz <flo@xinu.at>
-# Contributor: André Silva <emulatorman@hyperbola.info>
-# Contributor: Andreas Grapentin <andreas@grapentin.org>
-
-pkgname=asciidoc
-pkgver=8.6.10
-pkgrel=2
-pkgrel+=.parabola1
-pkgdesc='Text document format for short documents, articles, books and UNIX man pages.'
-arch=('any')
-url='https://www.methods.co.nz/asciidoc/'
-license=('GPL')
-depends=('python2' 'libxslt' 'docbook-xsl')
-optdepends=('lilypond: music-filter'
- 'imagemagick: music-filter (used in conjunction with lilypond)'
- 'source-highlight: source-highlight-filter'
- 'dblatex: pdf generation'
- 'lynx: text generation'
- 'w3m: text generation (alternative to lynx)')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/asciidoc/asciidoc/archive/${pkgver}.tar.gz")
-sha256sums=('9e52f8578d891beaef25730a92a6e723596ddbd07bfe0d2a56486fcf63a0b983')
-
-prepare() {
- cd ${pkgname}-${pkgver}
-
- # python2 fix
- #for file in asciidocapi.py a2x.py asciidoc.py filters/music/music2png.py filters/latex/latex2png.py \
- #filters/code/code-filter.py filters/graphviz/graphviz2png.py; do
- #sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
- #done
- #sed -i -e 's_sys:python_sys:python2_g' -e 's_sys3:python_sys3:python2_g' xhtml11.conf
- #sed -i 's_sys:python_sys:python2_g' xhtml11-quirks.conf
- #sed -i -e 's/{python}/{python2}/g' \
- #-e 's#{language@python:py:#{language@python2:py:#' \
- #filters/source/source-highlight-filter.conf \
- #html5.conf xhtml11.conf xhtml11-quirks.conf
- #sed -i -e "s#'python'#'python2'#g" filters/code/code-filter.py
- sed -i -e 's#python a2x.py#python2 a2x.py#' Makefile.in
-}
-
-build() {
- cd ${pkgname}-${pkgver}
-
- autoconf
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc
-}
-
-package() {
- cd ${pkgname}-${pkgver}
-
- make install DESTDIR=${pkgdir}
- make docs DESTDIR=${pkgdir}
-
- install -Dm644 asciidocapi.py \
- ${pkgdir}/usr/lib/python2.7/site-packages/asciidocapi.py
-
- # fix FS#21579 - [asciidoc] 8.6.2-2 "asciidoc" table style doesn't work (mismatched python version)
- #sed -i 's/python/python2/' \
- #${pkgdir}/etc/asciidoc/asciidoc.conf
-}