summaryrefslogtreecommitdiff
path: root/libre/audacious-plugins-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/audacious-plugins-libre/PKGBUILD')
-rw-r--r--libre/audacious-plugins-libre/PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/libre/audacious-plugins-libre/PKGBUILD b/libre/audacious-plugins-libre/PKGBUILD
index 90d5acdaa..ee0744317 100644
--- a/libre/audacious-plugins-libre/PKGBUILD
+++ b/libre/audacious-plugins-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 177005 2013-02-04 00:31:50Z bisson $
+# $Id: PKGBUILD 189208 2013-06-29 12:06:26Z bisson $
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: William Rea <sillywilly@gmail.com>
@@ -8,9 +8,9 @@
_pkgname=audacious-plugins
pkgname=audacious-plugins-libre
-pkgver=3.3.4
-pkgrel=2
-pkgdesc='Plugins for Audacious without unfree plugins'
+pkgver=3.4
+pkgrel=1
+pkgdesc='Plugins for Audacious, without nonfree plugins'
url='http://audacious-media-player.org/'
license=('GPL' 'GPL3' 'LGPL' 'custom:BSD')
arch=('i686' 'x86_64')
@@ -24,17 +24,17 @@ arch=('i686' 'x86_64')
#
# All the other custom licensed plugins I think are mostly modified BSD or ISC.
-provides=("audacious-plugins=$pkgver")
-replaces=("${pkgname%-libre}")
-conflicts=("${pkgname%-libre}")
+replaces=$_pkgname
+conflicts=$_pkgname
+provides=$_pkgname=$pkgver
makedepends=("audacious>=${pkgver}"
- 'oss' 'alsa-lib' 'pulseaudio' 'jack2' 'lame' 'libvorbis' 'flac'
+ 'oss-libre' 'alsa-lib' 'pulseaudio' 'jack2' 'lame' 'libvorbis' 'flac'
'mpg123' 'faad2' 'ffmpeg' 'libmodplug' 'fluidsynth' 'libcdio-paranoia' 'libsidplay' 'wavpack'
- 'libnotify' 'lirc-utils' 'curl' 'libmtp'
+ 'libnotify' 'lirc-utils-libre' 'curl' 'libmtp'
'neon' 'libmms' 'libcue')
-optdepends=('oss: Open Sound System v4 output'
+optdepends=('oss-libre: Open Sound System v4 output'
'alsa-lib: Advanced Linux Sound Arch. output'
'pulseaudio: PulseAudio output'
'jack2: Jack Audio Connection Kit output'
@@ -52,7 +52,7 @@ optdepends=('oss: Open Sound System v4 output'
'wavpack: WavPack input'
'libnotify: libnotify OSD'
- 'lirc-utils: LIRC'
+ 'lirc-utils-libre: LIRC'
'curl: AudioScrobbler Client'
'libmtp: Upload to MTP device'
@@ -61,9 +61,9 @@ optdepends=('oss: Open Sound System v4 output'
'libcue: CUE playlist format')
source=("http://distfiles.audacious-media-player.org/${_pkgname}-${pkgver}.tar.bz2")
-sha1sums=('6493f051417a201fc0e2de7ef36a709676f96607')
+sha1sums=('2b2f1d30f0b790e6cc3e00483ed4774b0fa1fc42')
-build() {
+prepare() {
# Retrieve upstream & remove plugin 'psf' due to issues mentioned above.
sed -i s/enable_psf=yes/enable_psf=no/ ${_pkgname}-$pkgver/configure
@@ -105,6 +105,10 @@ build() {
install -m644 LICENSE.voice_removal $l
install -m644 LICENSE.xfs $l
popd
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
./configure \
--prefix=/usr \