summaryrefslogtreecommitdiff
path: root/libre/base/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/base/PKGBUILD')
-rw-r--r--libre/base/PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/libre/base/PKGBUILD b/libre/base/PKGBUILD
index b068e6bbf..06e346306 100644
--- a/libre/base/PKGBUILD
+++ b/libre/base/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer (arch): Arch Linux Team
-# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Contributor: Eli Schwartz <eschwartz@archlinux.org>
-# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Maintainer: Parabola GNU/Linux-libre Team
+# Maintainer (Arch): Arch Linux Team
+# Contributor (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor (Arch): Eli Schwartz <eschwartz@archlinux.org>
pkgname=base
-pkgver=2
-pkgrel=2
+pkgver=3
+pkgrel=1
pkgrel+=.parabola1
-pkgdesc="Minimal package-set to define the essential Parabola GNU/Linux-libre systemd CLI system"
-url='https://www.parabola.nu'
-arch=('any')
+pkgdesc='Minimal package set to define a basic Parabola GNU/Linux-libre installation'
+url='https://www.archlinux.org'
+arch=('x86_64' 'i686' 'armv7h')
license=('GPL')
depends=(
# very very base
@@ -22,11 +22,15 @@ depends=(
'gettext' 'pciutils' 'psmisc' 'shadow' 'util-linux' 'bzip2' 'gzip' 'xz'
# distro defined requirements
- 'licenses' 'pacman' 'systemd' 'systemd-sysvcompat'
- 'systemd-libudev' 'systemd-udev' 'your-freedom'
+ 'licenses' 'pacman' 'parabola-keyring' 'systemd' 'systemd-sysvcompat'
+ 'your-freedom'
# networking, ping, etc
'iputils' 'iproute2'
)
-optdepends=('linux-libre: bare metal support'
- 'parabola-base: standard Parabola GNU/Linux-libre CLI system')
+depends_x86_64=('archlinux-keyring')
+depends_i686=('archlinux32-keyring')
+depends_armv7h=('archlinuxarm-keyring')
+optdepends=('linux-libre: bare metal support')
+
+# vim: ts=2 sw=2 et: