summaryrefslogtreecommitdiff
path: root/libre/blender/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/blender/PKGBUILD')
-rw-r--r--libre/blender/PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/libre/blender/PKGBUILD b/libre/blender/PKGBUILD
index 76c8a5aed..2b40070d6 100644
--- a/libre/blender/PKGBUILD
+++ b/libre/blender/PKGBUILD
@@ -12,14 +12,14 @@
# or simply roll with a new version. I usually choose the latter when the former seems
# unreasonable.
-# _gittag=v2.79-rc2
-_gitcommit=3c3d0898b0c1a1d7da70f4a1778d4360b3cfe5c8
+_gittag=v2.79
+#_gitcommit=3c3d0898b0c1a1d7da70f4a1778d4360b3cfe5c8
pkgbase='blender'
pkgname=("${pkgbase}" "${pkgbase}-addon-gimp" "${pkgbase}-addon-povray")
pkgver=2.79rc2
#[[ -n $_gitcommit ]] && pkgver=${pkgver}.git1.${_gitcommit}
-pkgrel='2.parabola1'
+pkgrel='5.parabola1'
epoch='17'
pkgdesc='A fully integrated 3D graphics creation suite, without nonfree CUDA support'
@@ -89,6 +89,8 @@ build() {
[[ "${CARCH}" = 'x86_64' || "${CARCH}" = 'i686' ]] && \
_SSE='ON' _SSE2='ON' || _SSE='OFF' _SSE2='OFF'
+ export CFLAGS="${CFLAGS} -DOPENVDB_3_ABI_COMPATIBLE"
+ export CXXFLAGS="${CXXFLAGS} -DOPENVDB_3_ABI_COMPATIBLE"
cmake -C../build_files/cmake/config/blender_release.cmake .. \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_BUILD_TYPE=Release \