summaryrefslogtreecommitdiff
path: root/libre/bogofilter-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/bogofilter-libre/PKGBUILD')
-rw-r--r--libre/bogofilter-libre/PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/libre/bogofilter-libre/PKGBUILD b/libre/bogofilter-libre/PKGBUILD
index c5718a9fd..42a33a113 100644
--- a/libre/bogofilter-libre/PKGBUILD
+++ b/libre/bogofilter-libre/PKGBUILD
@@ -1,33 +1,29 @@
-# $Id: PKGBUILD 146459 2012-01-11 15:21:47Z stephane $
+# $Id: PKGBUILD 183193 2013-04-18 17:14:00Z andyrtr $
# Maintainer: tobias <tobias@archlinux.org>
# Contributor: Low Kian Seong <fastmail_low@speedymail.org>
_pkgname=bogofilter
pkgname=bogofilter-libre
-pkgver=1.2.2
-pkgrel=5
-pkgdesc="A fast Bayesian spam filtering tool"
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="A fast Bayesian spam filtering tool, without noncommercial files"
arch=('i686' 'x86_64')
license=('GPL3')
url="http://bogofilter.sourceforge.net"
depends=('db' 'perl' 'gsl')
backup=('etc/bogofilter/bogofilter.cf')
-source=(http://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}.tar.xz)
-md5sums=('af9c7857c66b1884c820f54f23082701')
+source=(http://sourceforge.net/projects/${_pkgname}/files/${_pkgname}-current/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.bz2)
+md5sums=('c3ed7f483b83abcbf6d8c797084bd06e')
provides=("${_pkgname}=${pkgver}")
replaces=("${_pkgname}")
conflicts=("${_pkgname}")
-mksource() {
- [ -f ${_pkgname}-${pkgver}.tar.bz2 ] || wget http://sourceforge.net/projects/${_pkgname}/files/${_pkgname}-current/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.bz2
- tar xf ${_pkgname}-${pkgver}.tar.bz2
- # Remove noncommercial files.
- rm ${_pkgname}-${pkgver}/doc/bogofilter-SA-{2005-0{1,2},2010-01}
- tar cJf ${pkgname}-${pkgver}.tar.xz ${_pkgname}-${pkgver}
-}
-
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Remove noncommercial files.
+ rm doc/bogofilter-SA-{2005-0{1,2},2010-01}
+
./configure --prefix=/usr \
--sysconfdir=/etc/bogofilter \
--localstatedir=/var \