summaryrefslogtreecommitdiff
path: root/libre/calibre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/calibre/PKGBUILD')
-rw-r--r--libre/calibre/PKGBUILD74
1 files changed, 39 insertions, 35 deletions
diff --git a/libre/calibre/PKGBUILD b/libre/calibre/PKGBUILD
index 2b1042545..e56791a53 100644
--- a/libre/calibre/PKGBUILD
+++ b/libre/calibre/PKGBUILD
@@ -6,52 +6,61 @@
# Contributor (Arch): Larry Hajali <larryhaja@gmail.com>
# Contributor (Arch): Eli Schwartz <eschwartz93@gmail.com>
# Contributor: David P.<megver83@parabola.nu>
-# Maintainer: Jesús E.<heckyel@parabola.nu>
+# Contributor: Jesús E.<heckyel@parabola.nu>
+# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
pkgname=calibre
-_commit='2a4cfe3fdc292d794b3e65fb8461811b98e631a1'
-pkgver=3.11.1
-pkgrel=1.parabola1
+_commit='72011a66bf4f380a8d36c6fd9c3f6069e767539b'
+pkgver=3.12.0
+pkgrel=2.parabola1
_mathjax_ver=2.6.1
pkgdesc="Ebook management application, without nonfree decompression engine for RAR archives"
arch=('x86_64' 'i686' 'armv7h')
url="https://calibre-ebook.com/"
license=('GPL3')
-depends=('chmlib' 'icu' 'libmtp' 'libusbx' 'libwmf' 'mtdev'
- 'optipng' 'podofo' 'python2-apsw' 'python2-cssselect'
- 'python2-cssutils' 'python2-dateutil' 'python2-dbus' 'python2-dnspython'
- 'python2-dukpy' 'python2-html5-parser' 'python2-mechanize' 'python2-msgpack'
- 'python2-netifaces' 'python2-pillow' 'python2-psutil' 'python2-pygments'
- 'python2-pyqt5' 'python2-regex' 'qt5-svg' 'qt5-webkit')
-makedepends=('qt5-x11extras' 'xdg-utils' 'rapydscript-ng' 'python2-sphinx')
-optdepends=('ipython2: to use calibre-debug -g'
- 'poppler: required for converting pdf to html')
+depends=('python2-six' 'python2-dateutil' 'python2-cssutils' 'python2-dukpy'
+ 'python2-mechanize' 'podofo' 'libwmf'
+ 'chmlib' 'python2-lxml' 'libusbx' 'python2-html5-parser'
+ 'python2-pillow' 'shared-mime-info' 'python2-dnspython' 'python2-msgpack'
+ 'python2-pyqt5' 'python2-psutil' 'libmtp' 'python2-dbus'
+ 'python2-netifaces' 'python2-cssselect' 'python2-apsw' 'qt5-webkit'
+ 'qt5-svg' 'python2-regex' 'python2-pygments' 'mtdev'
+ 'desktop-file-utils' 'gtk-update-icon-cache' 'optipng' 'udisks2')
+# we don't want it to break whenever Arch pushes a new icu soname, nor
+# is it desirable to have it block every minor-version upgrade when
+# it's actually linked against no minor version in particular
+depends+=('icu>=60' 'icu<61')
+makedepends=('qt5-x11extras' 'xdg-utils')
+optdepends=('ipython2: to use calibre-debug'
+ # TODO: I don't know the mapping from poppler versions to sonames
+ 'poppler=0.61.1: required for converting pdf to html')
replaces=($pkgname-libre)
conflicts=($pkgname-libre)
-source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/Megver83/calibre/repository/archive.tar.gz?ref=$pkgver"
- "$pkgname-$pkgver.tar.gz.sig::https://gitlab.com/Megver83/calibre/raw/signatures/$pkgname-$pkgver-${_commit}.tar.gz.sig"
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/libreforks/calibre/repository/archive.tar.gz?ref=$pkgver"
+ "$pkgname-$pkgver.tar.gz.sig::https://gitlab.com/libreforks/calibre/raw/signatures/$pkgname-$pkgver-${_commit}.tar.gz.sig"
"$pkgname-translations.zip::https://github.com/kovidgoyal/${pkgname}-translations/archive/master.zip"
"MathJax-${_mathjax_ver}.tar.gz::https://github.com/kovidgoyal/MathJax/archive/${_mathjax_ver}.tar.gz")
-sha256sums=('b53c76b86eb1e739731f3625b99b57af9769eb1639f63faa6963065073e41a30'
+sha256sums=('ee9a4993b290846dbcc242e5116a41111935dbb41355f102569d6871b4386562'
'SKIP'
- '39ea2c430f50d1e02ce322798f22f668e4995605dd41b6e36c5fe2b9bceb1c7d'
+ '6e3f10901910f87f79840aa1222b0dba088ed5393e05c80489cab6db5686c30b'
'c746945d87a4e93ee801a44b6209986bfc901cb2f6c505628a2ed5793422fbb8')
validpgpkeys=('6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
'916FFBC76D2E641BA416BA53364F4E1483446AC5' # Jesús E.
)
prepare() {
- # move directories
+ # Parabola: rename from gitlab archive
mv "$pkgname-$pkgver-${_commit}" "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
- # Link translations to build dir
+ # Parabola: link translations to build dir
ln -sfT ../calibre-translations-master translations
+ # Remove unneeded files
+ rm -rf resources/${pkgname}-portable.*
+
# Desktop integration (e.g. enforce arch defaults)
- # Use uppercase naming scheme, don't create uninstaller.
- # xdg *cannot* be kludged into installing mime files properly.
sed -e "/self.create_uninstaller()/,/os.rmdir(config_dir)/d" \
-e "/cc(\['xdg-desktop-menu', 'forceupdate'\])/d" \
-e "/cc(\['xdg-mime', 'install', MIME\])/d" \
@@ -61,18 +70,14 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver"
-
- # Don't use the bootstrapper, since it tries to checkout/pull the
- # translations repo and generally touch the internet. Instead call each
- # *needed* subcommmand.
- # LANG='en_US.UTF-8' python2 setup.py bootstrap
+ cd "${pkgname}-${pkgver}"
LANG='en_US.UTF-8' python2 setup.py build
+ LANG='en_US.UTF-8' python2 setup.py gui
+ # Parabola
LANG='en_US.UTF-8' python2 setup.py iso639
LANG='en_US.UTF-8' python2 setup.py iso3166
LANG='en_US.UTF-8' python2 setup.py translations
- LANG='en_US.UTF-8' python2 setup.py gui
LANG='en_US.UTF-8' python2 setup.py resources
LANG='en_US.UTF-8' python2 setup.py man_pages
LANG='en_US.UTF-8' python2 setup.py recent_uas || true
@@ -80,20 +85,19 @@ build() {
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
- # If these directories don't exist, zsh completion, icons, and desktop files won't install.
install -d "${pkgdir}/usr/share/zsh/site-functions" \
- "${pkgdir}"/usr/share/{applications,desktop-directories,icons/hicolor}
+ "${pkgdir}"/usr/share/{applications,desktop-directories,icons/hicolor}
+
+ install -Dm644 resources/calibre-mimetypes.xml \
+ "${pkgdir}/usr/share/mime/packages/calibre-mimetypes.xml"
XDG_DATA_DIRS="${pkgdir}/usr/share" LANG='en_US.UTF-8' \
python2 setup.py install --staging-root="${pkgdir}/usr" --prefix=/usr
cp -a man-pages/ "${pkgdir}/usr/share/man"
- install -Dm644 resources/calibre-mimetypes.xml \
- "${pkgdir}/usr/share/mime/packages/calibre-mimetypes.xml"
-
# Compiling bytecode FS#33392
python2 -m compileall "${pkgdir}/usr/lib/calibre/"
python2 -O -m compileall "${pkgdir}/usr/lib/calibre/"