summaryrefslogtreecommitdiff
path: root/libre/debootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/debootstrap/PKGBUILD')
-rw-r--r--libre/debootstrap/PKGBUILD79
1 files changed, 31 insertions, 48 deletions
diff --git a/libre/debootstrap/PKGBUILD b/libre/debootstrap/PKGBUILD
index 4f915a4eb..043d9b60f 100644
--- a/libre/debootstrap/PKGBUILD
+++ b/libre/debootstrap/PKGBUILD
@@ -1,38 +1,30 @@
-# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
+# Maintainer (arch): Felix Yan <felixonmars@archlinux.org>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Andreas Grapentin <andreas@grapentin.org>
# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
# Contributor: André Silva <emulatorman@hyperbola.info>
pkgname=debootstrap
-pkgver=1.0.116
+pkgver=1.0.134
pkgrel=1
pkgrel+=.parabola2
-_pureospkgver=1.0.108
-_pureospkgrel=pureos2
-pkgdesc="Bootstrap a basic gNewSense and Trisquel system, without Debian support"
+pkgdesc="Bootstrap a basic Trisquel system, without Debian support"
arch=(any)
license=(GPL)
url="https://tracker.debian.org/pkg/debootstrap"
depends=(wget binutils)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/felixonmars/debootstrap/archive/$pkgver.tar.gz"
- "https://repo.puri.sm/pureos/pool/main/d/debootstrap/debootstrap_$_pureospkgver$_pureospkgrel.tar.gz"
+makedepends=(git)
+source=("git+https://salsa.debian.org/installer-team/debootstrap.git#tag=${pkgver}"
arch-detect.patch
- debootstrap.8
- gnewsense
- trisquel)
+ debootstrap.8)
optdepends=('gnupg: check release signatures'
'pureos-archive-keyring: check PureOS release signatures'
'trisquel-keyring: check Trisquel release signatures')
-sha512sums=('4b81bc56c6ac6e210aaceb06013882ba3cfe777d4173fd89d38a279fe57425302b86b2fb00ea2e19df2abfb7058909e1eb628f74f241612d865044b32e3481a4'
- '16888223cb3f4688ac468204bf4351080ac801456b990481602580f78666a034530b48d8bf6e989a53a393ab5edf6fdc80f5815be82fbfab3f9b845850da5d0b'
- '56e25f48027f99f7e720859a9e14fe769b1cbd6227c7a7e27e14c2fea88520109342d6e5b127dc34ce8cc40f46941a0c5157ad35cf8ef9b3e4323877a4b32d97'
- '0b3507756b8f29d19146df3201143ccbd71cfd1f7ef865d184079180612b90c046cabab59fe42d246bfe476ae8fd5c43e81ee2fc3ee06bbc1fc3e75d9f1382ca'
- '968ef005bf1f399b3400080b2ba65f1b32c067c49faadc1caa7ee524a85980f0a6625c7b06838e01bbd8b99a496492da77a38f0e17f0a81fc029ee611fe639b6'
- '06a352906de6f321f0bbd30667046eec3d9363774ba468d7dbe7c2d2cde92cca480ab4d595a84d594cd3f93ea0def1c67dc8f5bb1be6d669a29035ec289da668')
-
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd debootstrap-$pkgver
+ cd debootstrap
sed -i 's/sbin/bin/g' Makefile
@@ -51,7 +43,11 @@ prepare() {
# Remove (non-FSDG compliant) distributions's scripts
for SCRIPT in scripts/* ; do
case $SCRIPT in
- scripts/debian-common)
+ scripts/amber) # PureOS 9.0
+ ;;
+ scripts/debian-common) # Required by debuerreotype
+ ;;
+ scripts/robur) # Trisquel 2.0
;;
*)
rm -v $SCRIPT
@@ -59,44 +55,31 @@ prepare() {
esac
done
- # Add gNewSense script
- install -m644 $srcdir/gnewsense scripts
-
- # Add PureOS script
- install -m644 $srcdir/debootstrap/scripts/amber scripts/pureos
-
- # Add Trisquel script
- install -m644 $srcdir/trisquel scripts
-
# Enter to scripts dir
cd scripts
- # Create gNewSense symlinks
- ln -s gnewsense ucclia
- ln -s gnewsense parkes
-
# Create PureOS symlinks
- ln -s pureos amber
- ln -s pureos green
- ln -s pureos landing
- ln -s pureos purple
+ ln -s amber byzantium # PureOS 10.0
+ ln -s amber crimson # PureOS 11.0
+ ln -s amber landing # Based on Debian testing
# Create Trisquel symlinks
- ln -s trisquel awen
- ln -s trisquel belenos
- ln -s trisquel brigantia
- ln -s trisquel dagda
- ln -s trisquel dwyn
- ln -s trisquel etiona
- ln -s trisquel flidas
- ln -s trisquel robur
- ln -s trisquel slaine
- ln -s trisquel taranis
- ln -s trisquel toutatis
+ ln -s robur dwyn # Trisquel 3.0
+ ln -s robur awen # Trisquel 3.5
+ ln -s robur taranis # Trisquel 4.0
+ ln -s robur slaine # Trisquel 4.5
+ ln -s robur dagda # Trisquel 5.0
+ ln -s robur brigantia # Trisquel 5.5
+ ln -s robur toutatis # Trisquel 6.0
+ ln -s robur belenos # Trisquel 7.0
+ ln -s robur flidas # Trisquel 8.0
+ ln -s robur etiona # Trisquel 9.0
+ ln -s robur nabia # Trisquel 10.0
+ ln -s robur aramo # Trisquel 11.0
}
package() {
- cd debootstrap-$pkgver
+ cd debootstrap
make DESTDIR="$pkgdir" install
install -Dm644 debootstrap.8 "$pkgdir"/usr/share/man/man8/debootstrap.8