summaryrefslogtreecommitdiff
path: root/libre/distcc-nozeroconf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/distcc-nozeroconf/PKGBUILD')
-rw-r--r--libre/distcc-nozeroconf/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/libre/distcc-nozeroconf/PKGBUILD b/libre/distcc-nozeroconf/PKGBUILD
new file mode 100644
index 000000000..2537b2f87
--- /dev/null
+++ b/libre/distcc-nozeroconf/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id: PKGBUILD 90657 2013-05-13 14:21:37Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+_pkgname=distcc
+pkgname=distcc-nozeroconf
+pkgver=3.1
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+pkgrel=11
+pkgdesc="A distributed C, C++, Obj C compiler (without zeroconf support)"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/distcc/"
+license=('GPL')
+depends=('gcc' 'popt')
+makedepends=('gtk2' 'pkgconfig' 'python2')
+optdepends=('gtk2: for distccmon-gnome'
+ 'python2')
+backup=('etc/conf.d/distccd'
+ 'etc/distcc/hosts')
+source=(http://distcc.googlecode.com/files/${_pkgname}-${pkgver}.tar.bz2
+ distccd.conf.d
+ distccd.service)
+md5sums=('a1a9d3853df7133669fffec2a9aab9f3'
+ '239aae53250e3e35288cba566bc0bbf1'
+ '09f0688da9c1840e518d2593bd5c3830')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ [ -f Makefile ] || PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ --with-gtk \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --without-avahi
+
+ make WERROR_CFLAGS= INCLUDESERVER_PYTHON=/usr/bin/python2
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+# make TEST_PYTHON=/usr/bin/python2 check
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" INCLUDESERVER_PYTHON=/usr/bin/python2 install
+ install -D -m644 ${srcdir}/distccd.conf.d ${pkgdir}/etc/conf.d/distccd
+
+ install -d ${pkgdir}/usr/lib/${_pkgname}/bin
+ ln -sf /usr/bin/${_pkgname} ${pkgdir}/usr/lib/${_pkgname}/bin/cc
+ ln -sf /usr/bin/${_pkgname} ${pkgdir}/usr/lib/${_pkgname}/bin/gcc
+ ln -sf /usr/bin/${_pkgname} ${pkgdir}/usr/lib/${_pkgname}/bin/g++
+ ln -sf /usr/bin/${_pkgname} ${pkgdir}/usr/lib/${_pkgname}/bin/c++
+ ln -sf /usr/bin/${_pkgname} ${pkgdir}/usr/lib/${_pkgname}/bin/cpp
+
+ install -Dm0644 $srcdir/distccd.service $pkgdir/usr/lib/systemd/system/distccd.service
+}