summaryrefslogtreecommitdiff
path: root/libre/ecasound-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/ecasound-libre/PKGBUILD')
-rw-r--r--libre/ecasound-libre/PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/libre/ecasound-libre/PKGBUILD b/libre/ecasound-libre/PKGBUILD
index 30cbbc641..6fbdd3fb3 100644
--- a/libre/ecasound-libre/PKGBUILD
+++ b/libre/ecasound-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: PKGBUILD 180827 2013-03-26 13:29:04Z schiv $
# Maintainer: Ray Rashif <schiv@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
@@ -7,13 +7,12 @@
_pkgname=ecasound
pkgname=ecasound-libre
pkgver=2.9.0
-pkgrel=2.1
-pkgdesc="A software package designed for multitrack audio processing (without nonfree faac recommendation)"
+pkgrel=3
+pkgdesc="A software package designed for multitrack audio processing, without nonfree faac recommendation"
arch=('i686' 'x86_64')
url="http://www.eca.cx/ecasound/"
license=('GPL' 'LGPL')
-depends=('audiofile' 'liblo'
- 'liboil' 'lilv')
+depends=('audiofile' 'liblo' 'liboil' 'lilv')
makedepends=('python2' 'ruby')
optdepends=('python2: ecamonitor, ECI API'
'ruby: ECI API'
@@ -27,14 +26,16 @@ replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
options=('!libtool')
-source=(http://ecasound.seul.org/download/$_pkgname-$pkgver.tar.gz)
-md5sums=('05e7d4664cdf4c7a138c098e9506a551')
+source=("http://ecasound.seul.org/download/$_pkgname-$pkgver.tar.gz"
+ 'ruby2.patch')
+md5sums=('05e7d4664cdf4c7a138c098e9506a551'
+ '6909dbd4f67f76d3bd31ce7c7fe16212')
build() {
cd "$srcdir/$_pkgname-$pkgver"
- # use vendor_ruby for ruby files
- sed -e 's/CONFIG\["sitedir"\]/CONFIG\["vendordir"\]/' -i configure
+ # fix ruby 2.0 incompatibility + use vendor_ruby for ruby files
+ patch -Np1 -i "$srcdir/ruby2.patch"
PYTHONPATH=/usr/bin/python2 ./configure \
--prefix=/usr \