summaryrefslogtreecommitdiff
path: root/libre/filesystem/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/filesystem/PKGBUILD')
-rw-r--r--libre/filesystem/PKGBUILD83
1 files changed, 54 insertions, 29 deletions
diff --git a/libre/filesystem/PKGBUILD b/libre/filesystem/PKGBUILD
index f4f4438a7..a37813e89 100644
--- a/libre/filesystem/PKGBUILD
+++ b/libre/filesystem/PKGBUILD
@@ -1,26 +1,39 @@
-# Maintainer (Arch): Sébastien Luttringer
-# Contributor (Arch): Tom Gundersen <teg@jklm.no>
+# Maintainer (arch): Sébastien Luttringer
+# Contributor: Tom Gundersen <teg@jklm.no>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
+
+# parabola changes and rationale:
+# - parabola branding (os-release,motd,icon,logo)
+# - disable dotnet telemetry (redmine #2894)
+
pkgname=filesystem
-pkgver=2020.08.21
+pkgver=2023.09.18
pkgrel=1
pkgrel+=.parabola1
pkgdesc='Base Parabola GNU/Linux-libre files'
arch=('x86_64')
-arch+=('i686' 'armv7h' 'ppc64le')
+arch+=('armv7h' 'i686' 'ppc64le')
license=('GPL')
url='https://www.parabola.nu'
depends=('iana-etc')
backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
- 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/motd' 'etc/nsswitch.conf'
+ 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/nsswitch.conf'
'etc/passwd' 'etc/profile' 'etc/resolv.conf' 'etc/securetty'
- 'etc/shadow' 'etc/shells')
+ 'etc/shadow' 'etc/shells' 'etc/subuid' 'etc/subgid')
+backup+=('etc/motd')
source=('crypttab' 'env-generator' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
- 'issue' 'ld.so.conf' 'locale.sh' 'motd' 'nsswitch.conf' 'os-release'
- 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells' 'sysctl'
- 'sysusers' 'tmpfiles' 'parabola.svg' 'parabola.png')
+ 'issue' 'ld.so.conf' 'locale.sh' 'nsswitch.conf' 'os-release' 'profile'
+ 'passwd' 'resolv.conf' 'securetty' 'shadow' 'shells' 'sysctl' 'sysusers'
+ 'tmpfiles' 'subuid' 'subgid' 'archlinux-logo.svg' 'archlinux-logo.png'
+ 'archlinux-logo-text.svg' 'archlinux-logo-text-dark.svg')
+source=( ${source[*]//archlinux-logo/parabola-logo} )
+source+=('motd')
+source+=('disable-dotnet-telemetry.sh')
+# NOTE: the commented files below, are those which should differ from arch
sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
'ed0cb4f1db4021f8c3b5ce78fdf91d2c0624708f58f36c9cf867f4d93c3bc6da'
'e54626e74ed8fee4173b62a545ab1c3a3a069e4217a0ee8fc398d9933e9c1696'
@@ -28,23 +41,36 @@ sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
'90d879374f77bac47f132164c1e7fc4892e994ff1d1ac376efa0c1c26ea37273'
'4d7b647169063dfedbff5e1e22cee77bd1a4183dbcfd5e802e68939da4bbf733'
'd9cd8a77d9e0aa5e90d7f4ed74c8745c17b525e720e28e4c44364150003c35f9'
- '8b8f24af3454e87b4e316b4978d0de7958a98cc44606aa801d9696d2c21f4385'
+ '8b8f24af3454e87b4e316b4978d0de7958a98cc44606aa801d9696d2c21f4385' # issue (branding)
'dad04a370e488aa85fb0a813a5c83cf6fd981ce01883fc59685447b092de84b5'
'8ca2d8eef6fb5143c9ef7e9174ccfef59ac7ad2deee243574cd10c763156cc10'
- 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
- '3b821d881a147977e251c522d722626881229d8bc150447673f39f28876ac749'
- '1fb18c22836c5b679d183a504e594f14d2fdbeb7ce97dd3de5a0c88299f3d597'
+ 'c8ee7a9faf798caab178ec51afae4146f1efd8a716b7acedf28345b6c75f9697'
+ '359623c74da854d93e7dcc5335f3e3c95c378af75f640fc728596268ce4391a9' # os-release (branding)
+ '8f08231922fe185d3132f9aedded5cd688fb7c482a6f6f272402ded82fa4849a'
'5e06477834f51abf42ea4e8dc199632afc6afbfd8c44354685a271e9a48d2c0a'
- '7bb7e910d7bc073e34543f1e42b709e85efb6f1f7c0e5c9ffe0e207f8ca36fb6'
'5557d8e601b17a80d1ea7de78a9869be69637cb6a02fbfe334e22fdf64e61d4c'
'd88be2b45b43605ff31dd83d6a138069b6c2e92bc8989b7b9ab9eba8da5f8c7b'
'6e13705ac4d6f69cdba118c6b70c722346fd3c45224133e6bbfe28aca719563c'
- 'c390b31fffc4a2b5d78ae8c89f5317aadef1f71baac09cfb467b675db1406d61'
+ 'ec289c03aa0d150e90e8287f001c8e6552ab9dd54f450bdb5c2d2254e477965b'
'89e43a0b7028f52d5c8e7fb961d962c4b4f4e9595880a6157274ddb2c7c0b6b4'
- '04dd4cbe5078f5181176ade3a82f333e3f48091b118360d69cc45a3526503818'
- '618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9'
- 'cb8ece3772744ef162d0ff6018e6a7051889c2aba1bf6439ba9e74a64ac46927'
- '826c61cb40bb0b31e2071b21e04ad7f8c6aabe2817e681246569ae9dff81cd9b')
+ '59877ca8c00192776d06d0c11087083e31e5c5ba6830c4faaa924d858df42f8a' # sysusers (branding)
+ '5d8e61479f0093852365090e84d8d95b1e7fccfab068274ee25863bde6ff3e07'
+ 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
+ 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
+ 'd5f0a4f75761afd5ebbc6970ac9aba5be3c28bb660adf7118353a0e018911e68' # parabola-logo.svg
+ 'c6486f4c9456fa62a75727adfcc8f2403a1a9fac29386f942c0678c109cc72e8' # parabola-logo.png
+ '09838fea00c5ceff6e7ed28bb1b6d62feb1e2471df9fe5a4328071ecb9e837f3' # parabola-logo-text.svg
+ 'bc9be3442fab17ac6990814db4c0cc76c2ac6112c70a6c103530f607aa54c11e') # parabola-logo-text-dark.svg
+sha256sums+=('0018e0387155ee65472f71f0003fcbcb863355d12442150922e7156da12cabad') # motd
+sha256sums+=('0869a4e09afceabf9dbc3c46622b254e373eda48af71e2936acd0652c7d3518e') # disable-dotnet-telemetry.sh
+
+
+prepare() {
+ # inject OS variant information into os-release
+ local init='SystemD'
+ sed -i "s|@VARIANT@|${CARCH} ${init} Edition|" "${srcdir}"/os-release
+ sed -i "s|@VARIANT_ID@|${CARCH}-${init,,}|" "${srcdir}"/os-release
+}
package() {
cd "$pkgdir"
@@ -63,8 +89,8 @@ package() {
# setup /etc and /usr/share/factory/etc
install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
- for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf \
- passwd resolv.conf securetty shells profile; do
+ for f in fstab group host.conf hosts issue ld.so.conf nsswitch.conf \
+ passwd resolv.conf securetty shells profile subuid subgid; do
install -m644 "$srcdir"/$f etc/
install -m644 "$srcdir"/$f usr/share/factory/etc/
done
@@ -73,11 +99,15 @@ package() {
install -m600 "$srcdir"/$f etc/
install -m600 "$srcdir"/$f usr/share/factory/etc/
done
+ touch etc/arch-release
touch etc/parabola-release
- ln -sv parabola-release etc/arch-release
+ install -m644 "$srcdir"/motd etc/
install -m644 "$srcdir"/locale.sh etc/profile.d/locale.sh
install -Dm644 "$srcdir"/os-release usr/lib/os-release
+ # stop-gap fix for https://labs.parabola.nu/issues/2894
+ install -m644 "$srcdir"/disable-dotnet-telemetry.sh etc/profile.d/disable-dotnet-telemetry.sh
+
# setup /var
for d in cache local opt log/old lib/misc empty; do
install -d -m755 var/$d
@@ -100,14 +130,11 @@ package() {
# add lib symlinks
ln -s usr/lib lib
+ [[ $CARCH = 'ppc64le' ]] || \
[[ $CARCH = 'x86_64' ]] && {
ln -s usr/lib lib64
ln -s lib usr/lib64
}
- [[ $CARCH = 'powerpc64le' ]] && {
- ln -s usr/lib lib64
- ln -s lib usr/lib64
- }
# add bin symlinks
ln -s usr/bin bin
@@ -133,7 +160,5 @@ package() {
install -D -m755 "$srcdir"/env-generator usr/lib/systemd/system-environment-generators/10-arch
# add logo
- install -D -m644 "$srcdir"/parabola.{svg,png} usr/share/pixmaps
+ install -D -m644 "$srcdir"/parabola-logo{.png,.svg,-text.svg,-text-dark.svg} usr/share/pixmaps
}
-
-# vim:set ts=2 sw=2 et: