summaryrefslogtreecommitdiff
path: root/libre/glib2-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/glib2-static/PKGBUILD')
-rw-r--r--libre/glib2-static/PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/libre/glib2-static/PKGBUILD b/libre/glib2-static/PKGBUILD
index 5f0c284f2..2041c3800 100644
--- a/libre/glib2-static/PKGBUILD
+++ b/libre/glib2-static/PKGBUILD
@@ -3,31 +3,40 @@
pkgbase=glib2
pkgname=glib2-static
-pkgver=2.48.0
-pkgrel=1.1
-pkgdesc="Common C routines used by GTK+ and other libs (static libraries only)"
+pkgver=2.49.7+6+g3602f93
+pkgrel=1
+pkgdesc="Low level core library (static libraries only)"
url="http://www.gtk.org/"
arch=(i686 x86_64 armv7h)
-makedepends=('python')
-source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
+makedepends=('python' 'git')
+_commit=3602f934855a484c5eec28f12a6535e14de1778d
+source=("git://git.gnome.org/glib#commit=$_commit"
revert-warn-glib-compile-schemas.patch)
-sha256sums=('744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34'
+sha256sums=('SKIP'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
+pkgver() {
+ cd glib
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
- cd glib-$pkgver
+ cd glib
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd glib-$pkgver
+ cd glib
./configure --prefix=/usr --libdir=/usr/lib \
--disable-fam --enable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
check() {
- cd glib-$pkgver
+ cd glib
+ # Takes an effing long time
#make -k check || :
}
@@ -36,7 +45,7 @@ package() {
options=('staticlibs')
license=('LGPL')
- cd glib-$pkgver
+ cd glib
make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
# remove conflicting files