summaryrefslogtreecommitdiff
path: root/libre/grub/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/grub/PKGBUILD')
-rw-r--r--libre/grub/PKGBUILD30
1 files changed, 28 insertions, 2 deletions
diff --git a/libre/grub/PKGBUILD b/libre/grub/PKGBUILD
index 14efe54da..f4dc27eb8 100644
--- a/libre/grub/PKGBUILD
+++ b/libre/grub/PKGBUILD
@@ -39,7 +39,7 @@ pkgname=('grub')
'grub-omap3_beagle_xm' 'grub-omap3_beagle_xm_ab')
pkgdesc='GNU GRand Unified Bootloader (2), (Parabola rebranded)'
pkgver='2.02'
-pkgrel='4.parabola1'
+pkgrel='6.parabola1'
epoch='2'
url='https://www.gnu.org/software/grub/'
arch=('x86_64' 'i686' 'armv7h')
@@ -80,6 +80,9 @@ source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
'0004-add-GRUB_COLOR_variables.patch'
'0005-Allow_GRUB_to_mount_ext234_filesystems_that_have_the_encryption_feature.patch'
'0006-tsc-Change-default-tsc-calibration-method-to-pmtimer-on-EFI-systems.patch'
+ '0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch'
+ '0008-Fix-packed-not-aligned-error-on-GCC-8.patch'
+ '0009-xfs-Accept-filesystem-with-sparse-inodes.patch'
'grub.default'
'0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch'
'0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch'
@@ -97,6 +100,9 @@ sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
'a5198267ceb04dceb6d2ea7800281a42b3f91fd02da55d2cc9ea20d47273ca29'
'535422c510a050d41efe7720dbe54de29e04bdb8f86fd5aea5feb0b24f7abe46'
'c38f2b2caae33008b35a37d8293d8bf13bf6fd779a4504925da1837fd007aeb5'
+ 'e43566c4fe3b1b87e677167323d4716b82ac0810410a9d8dc7fbf415c8db2b8a'
+ 'e84b8de569c7e6b73263758c35cf95c6516fde85d4ed451991427864f6a4e5a8'
+ 'fcd5a626d4af33665d041ce42df813f1f198d8230ea186481b155a5b676f3b87'
'959f3d8d65d9504df798924554c3de0e92dfcd39e087b099a5f5e0a9b7885102'
'9ece1db537a989ce4dc55ece471883e19b8ab16902f8c4feb68436c3b5700f71'
'de71452b9b0fbfb08ea742e9fa217ab34fddf6312452f155fb9d82ebf1c024a5'
@@ -124,6 +130,15 @@ prepare() {
msg "Patch to change default tsc calibration method to pmtimer on EFI systems"
patch -Np1 -i "${srcdir}/0006-tsc-Change-default-tsc-calibration-method-to-pmtimer-on-EFI-systems.patch"
+ msg "Support multiple early initrd images"
+ patch -Np1 -i "${srcdir}/0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch"
+
+ msg "Fix packed-not-aligned error on GCC 8"
+ patch -Np1 -i "${srcdir}/0008-Fix-packed-not-aligned-error-on-GCC-8.patch"
+
+ msg "xfs: Accept filesystem with sparse inodes"
+ patch -Np1 -i "${srcdir}/0009-xfs-Accept-filesystem-with-sparse-inodes.patch"
+
msg 'Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme'
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"
@@ -162,11 +177,12 @@ _build_grub-efi() {
unset LDFLAGS
unset MAKEFLAGS
- msg 'Run autogen.sh for ${_EFI_ARCH} EFI build'
+ msg "Run autogen.sh for ${_EFI_ARCH} EFI build"
./autogen.sh
msg "Run ./configure for ${_EFI_ARCH} EFI build"
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform="efi" \
--target="${_EFI_ARCH}" \
--disable-efiemu \
@@ -211,6 +227,7 @@ _build_grub-xen() {
msg "Run ./configure for ${_XEN_ARCH} XEN build"
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform='xen' \
--target="${_XEN_ARCH}" \
--disable-efiemu \
@@ -262,6 +279,7 @@ _build_grub-bios() {
msg 'Run ./configure for BIOS build'
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform='pc' \
--target='i386' \
"${_EFIEMU}" \
@@ -306,6 +324,8 @@ _build_grub-qemu() {
msg 'Run ./configure for QEMU build'
./configure \
+ FREETYPE="pkg-config freetype2" \
+ BUILD_FREETYPE="pkg-config freetype2" \
--with-platform='qemu' \
--target='i386' \
--disable-efiemu \
@@ -350,6 +370,7 @@ _build_grub-ieee1275() {
msg 'Run ./configure for IEEE1275 (OpenFirmware) build'
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform='ieee1275' \
--target='i386' \
--disable-efiemu \
@@ -394,6 +415,8 @@ _build_grub-libreboot() {
msg 'Run ./configure for Libreboot build'
./configure \
+ FREETYPE="pkg-config freetype2" \
+ BUILD_FREETYPE="pkg-config freetype2" \
--with-platform='coreboot' \
--target='i386' \
--disable-efiemu \
@@ -438,6 +461,7 @@ _build_grub-multiboot() {
msg 'Run ./configure for Multiboot build'
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform='multiboot' \
--target='i386' \
--disable-efiemu \
@@ -482,6 +506,7 @@ _build_grub-emu() {
msg 'Run ./configure for emu build'
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform='emu' \
--target="${_EMU_ARCH}" \
--enable-mm-debug \
@@ -530,6 +555,7 @@ _build_grub-uboot() {
msg 'Run ./configure for U-Boot build'
./configure \
+ FREETYPE="pkg-config freetype2" \
--with-platform='uboot' \
--target='arm' \
--disable-efiemu \