summaryrefslogtreecommitdiff
path: root/libre/grub/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/grub/PKGBUILD')
-rw-r--r--libre/grub/PKGBUILD61
1 files changed, 31 insertions, 30 deletions
diff --git a/libre/grub/PKGBUILD b/libre/grub/PKGBUILD
index 6dbef9f66..8c75d67e6 100644
--- a/libre/grub/PKGBUILD
+++ b/libre/grub/PKGBUILD
@@ -36,12 +36,12 @@ pkgname=('grub')
'grub-omap3_beagle_xm' 'grub-omap3_beagle_xm_ab')
pkgdesc='GNU GRand Unified Bootloader (2), (Parabola rebranded)'
pkgver='2.02.beta3'
-pkgrel='1.parabola2'
+pkgrel='3.parabola1'
epoch='1'
url='https://www.gnu.org/software/grub/'
arch=('x86_64' 'i686' 'armv7h')
license=('GPL3')
-backup=('etc/default/grub' 'etc/grub.d/40_custom')
+backup=('boot/grub/grub.cfg' 'etc/default/grub' 'etc/grub.d/40_custom')
install="${pkgname}.install"
options=('!makeflags')
depends=('sh' 'xz' 'gettext' 'device-mapper')
@@ -74,16 +74,16 @@ source=("grub-${_pkgver}::git+git://git.sv.gnu.org/grub.git#tag=${_GRUB_GIT_TAG}
"http://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz"
"http://ftp.gnu.org/gnu/unifont/unifont-${_UNIFONT_VER}/unifont-${_UNIFONT_VER}.bdf.gz.sig"
'0001-Fix-security-issue-when-reading-username-and-passwor.patch'
- 'grub-10_linux-20_linux_xen-detect-parabola-initramfs.patch'
- 'grub-add-GRUB_COLOR_variables.patch'
- '60_memtest86+'
+ '0003-10_linux-20_linux_xen-detect-parabola-initramfs.patch'
+ '0004-add-GRUB_COLOR_variables.patch'
+ '0005-10_linux-fix-grouping-of-tests.patch'
'grub.default'
- 'grub-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch'
- 'grub-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch'
- 'grub-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch'
- 'grub-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch'
- 'grub-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch'
- 'grub-10_linux-20_linux_xen-rebrand-free-distros.patch')
+ '0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch'
+ '0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch'
+ '0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch'
+ '0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch'
+ '0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch'
+ '0003-10_linux-20_linux_xen-rebrand-free-distros.patch')
md5sums=('SKIP'
'SKIP'
@@ -92,7 +92,7 @@ md5sums=('SKIP'
'9589ec46a04f9bb4d5da987340a4a324'
'3a9bb9bafe0062388e11f72f0e80ba7e'
'e506ae4a9f9f7d1b765febfa84e10d48'
- 'be55eabc102f2c60b38ed35c203686d6'
+ 'f1999315bbd25b4b9359919ce9b36144'
'8d1dd54ae4a1b550c097e056892ce953'
'a46695e19b588a53b8bac9e3b3c56096'
'803f5b5f56ba6d74ca84aea67659116e'
@@ -111,21 +111,25 @@ _pkgver() {
prepare() {
cd "${srcdir}/grub-${_pkgver}/"
- msg 'CVE-2015-8370'
+ msg 'Patch to fix CVE-2015-8370'
+ # CVE-2015-8370
patch -Np1 -i "${srcdir}/0001-Fix-security-issue-when-reading-username-and-passwor.patch"
msg 'Patch to detect of Parabola GNU/Linux-libre initramfs images by grub-mkconfig'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-parabola-initramfs.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-parabola-initramfs.patch"
msg 'Patch to enable GRUB_COLOR_* variables in grub-mkconfig'
## Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
- patch -Np1 -i "${srcdir}/grub-add-GRUB_COLOR_variables.patch"
+ patch -Np1 -i "${srcdir}/0004-add-GRUB_COLOR_variables.patch"
+
+ msg 'Patch to fix grouping of tests for GRUB_DEVICE'
+ patch -Np1 -i "${srcdir}/0005-10_linux-fix-grouping-of-tests.patch"
msg 'Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme'
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "${srcdir}/grub-${_pkgver}/configure.ac"
msg 'Rebranding for some free distros'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-rebrand-free-distros.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-rebrand-free-distros.patch"
msg "Fix mkinitcpio 'rw' FS#36275"
sed 's| ro | rw |g' -i "${srcdir}/grub-${_pkgver}/util/grub.d/10_linux.in"
@@ -257,7 +261,7 @@ _build_grub-bios() {
unset MAKEFLAGS
cd "${srcdir}/grub-${_pkgver}-bios"
-
+
msg 'Run autogen.sh for BIOS build'
./autogen.sh
@@ -773,9 +777,6 @@ package_grub() {
msg 'Package grub Multiboot stuff'
_package_grub-multiboot
-
- msg 'Install extra /etc/grub.d/ files'
- install -D -m0755 "${srcdir}/60_memtest86+" "${pkgdir}/etc/grub.d/60_memtest86+"
elif [[ "${CARCH}" = 'armv7h' ]]; then
msg 'Package grub U-Boot stuff'
_package_grub-uboot
@@ -802,7 +803,7 @@ package_grub-am335x_bone() {
cd "${srcdir}/grub-${_pkgver}-uboot_am335x-bone/"
msg 'Patch to detect am335x-bone device tree blob file (dtb)'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
msg 'Package grub U-Boot stuff'
## _package_grub-uboot
@@ -820,7 +821,7 @@ package_grub-am335x_bone() {
## msg 'Patch to detect am335x-bone device tree blob file (dtb)'
## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
+ ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-am335x_bone+am335x_boneblack-devicetree-file.patch"
}
package_grub-omap3_beagle() {
@@ -836,7 +837,7 @@ package_grub-omap3_beagle() {
cd "${srcdir}/grub-${_pkgver}-uboot_omap3_beagle/"
msg 'Patch to detect omap3_beagle device tree blob file (dtb)'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
msg 'Package grub U-Boot stuff'
## _package_grub-uboot
@@ -854,7 +855,7 @@ package_grub-omap3_beagle() {
## msg 'Patch to detect omap3_beagle device tree blob file (dtb)'
## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
+ ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle-devicetree-file.patch"
}
package_grub-omap3_beagle_xm() {
@@ -870,7 +871,7 @@ package_grub-omap3_beagle_xm() {
cd "${srcdir}/grub-${_pkgver}-uboot_omap3_beagle_xm/"
msg 'Patch to detect omap3_beagle_xm device tree blob file (dtb)'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
msg 'Package grub U-Boot stuff'
## _package_grub-uboot
@@ -888,7 +889,7 @@ package_grub-omap3_beagle_xm() {
## msg 'Patch to detect omap3_beagle_xm device tree blob file (dtb)'
## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
+ ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm-devicetree-file.patch"
}
package_grub-omap3_beagle_xm_ab() {
@@ -904,7 +905,7 @@ package_grub-omap3_beagle_xm_ab() {
cd "${srcdir}/grub-${_pkgver}-uboot_omap3_beagle_xm_ab/"
msg 'Patch to detect omap3_beagle_xm_ab device tree blob file (dtb)'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
msg 'Package grub U-Boot stuff'
## _package_grub-uboot
@@ -922,7 +923,7 @@ package_grub-omap3_beagle_xm_ab() {
## msg 'Patch to detect omap3_beagle_xm_ab device tree blob file (dtb)'
## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
+ ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-omap3_beagle_xm_ab-devicetree-file.patch"
}
package_grub-udoo() {
@@ -937,7 +938,7 @@ package_grub-udoo() {
cd "${srcdir}/grub-${_pkgver}-uboot_udoo/"
msg 'Patch to detect udoo device tree blob file (dtb)'
- patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"
+ patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"
msg 'Package grub U-Boot stuff'
## _package_grub-uboot
@@ -955,5 +956,5 @@ package_grub-udoo() {
## msg 'Patch to detect udoo device tree blob file (dtb)'
## cd "${pkgdir}/etc/grub.d/"
- ## patch -Np1 -i "${srcdir}/grub-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"
+ ## patch -Np1 -i "${srcdir}/0003-10_linux-20_linux_xen-detect-udoo-devicetree-file.patch"
}