summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD45
1 files changed, 34 insertions, 11 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index eebf10e57..359dd684b 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -1,10 +1,10 @@
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
# Contributor: Figue <ffigue at gmail>
# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
# Contributor (Parabola): vando <facundo@esdebian.org>
-# Contributor (Parabola): André Silva <emulatorman@lavabit.com>
-# Contributor (Parabola): Márcio Silva <coadde@lavabit.com>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
# Thank you very much to the older contributors:
# Contributor: evr <evanroman at gmail>
@@ -14,7 +14,7 @@ _pgo=true
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=21.0
+_debver=22.0
_debrel=1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -22,20 +22,21 @@ debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=iceweasel
pkgname=iceweasel-libre
pkgver=$_debver.$_debrel
-pkgrel=3
+pkgrel=1
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
license=(MPL GPL LGPL)
depends=(alsa-lib dbus-glib desktop-file-utils gtk2 gstreamer0.10-base hicolor-icon-theme hunspell libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(autoconf2.13 diffutils imagemagick libidl2 librsvg libxslt mesa pkg-config python2 quilt unzip zip)
+makedepends=(autoconf2.13 diffutils imagemagick libidl2 libpulse librsvg libxslt mesa pkg-config python2 quilt unzip zip)
[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
options=(!emptydirs !makeflags)
if $_pgo; then
makedepends+=(xorg-server-xvfb)
options+=(!ccache)
fi
-optdepends=('networkmanager: Location detection via available WiFi networks')
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'libpulse: PulseAudio audio driver')
url="http://packages.debian.org/experimental/${_pkgname}"
install=iceweasel.install
replaces=('firefox')
@@ -51,18 +52,22 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
vendor.js
shared-libs.patch
replace-urls.txt
+ $_pkgname-22.0-do-not-fallback-to-manual-proxy-settings.patch
+ $_pkgname-20.0.1-fixed-loading-icon.png
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch)
-md5sums=('0a7c51bb494463c327af918bae6c4ee4'
- 'c17121a4ffd40f463e16d7828445d96e'
- 'e1e903ca91997f18b428c54ef604f27d'
+md5sums=('45d7121606cc3b21cd2797c87b5dc3bd'
+ 'bf0440dd8c31527359d797daaf0d3edd'
+ '2d7ac85c32df6a4ccfcc6de7a1420bf7'
'383e8e2a97a8b13fe56d153adb6878b6'
- '2930f3bffe0d7a6b9845f8c006821bc2'
+ '0bbedfc161291de9dc61c531bf062c22'
'7b9e5996dd9fe0b186a43a297db1c6b5'
'abf5ecb74caa857abb42bcfbb3442d9c'
'0c26941504d3f2abed759221e9bb5de1'
'52e52f840a49eb1d14be1c0065b03a93'
'a8fc4658d45b6bf9350023e5c3f34e56'
- '85e67561e0e491cd538ce018dfc2d948')
+ 'bc27a39d08ab3f6705e487c85598d8bf'
+ '6e335a517c68488941340ee1c23f97b0'
+ '86d4045285a9a15c20a62f46535809cb')
prepare() {
export DEBIAN_BUILD="mozilla-release"
@@ -131,6 +136,10 @@ prepare() {
echo 'ac_add_options --disable-jemalloc' >> .mozconfig
fi
+ # Should be fixed in Iceweasel 23
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=817533
+ patch -Np1 -i ../$_pkgname-22.0-do-not-fallback-to-manual-proxy-settings.patch
+
# Fix PRE_RELEASE_SUFFIX
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
browser/base/Makefile.in
@@ -143,15 +152,27 @@ prepare() {
# configure script misdetects the preprocessor without an optimization level
# https://bugs.archlinux.org/task/34644
sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
+
+ # Fix tab loading icon (flickers with libpng 1.6)
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
+ cp "$srcdir/$_pkgname-20.0.1-fixed-loading-icon.png" \
+ browser/themes/linux/tabbrowser/loading.png
}
build() {
+ export DEBIAN_BUILD="mozilla-release"
+
cd "$srcdir/$DEBIAN_BUILD"
export PATH="$srcdir/path:$PATH"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
export PYTHON="/usr/bin/python2"
+ # Work around memory address space exhaustion during linking on i686
+ if [[ $CARCH == i686 ]]; then
+ LDFLAGS+=' -Wl,--no-keep-memory'
+ fi
+
if $_pgo; then
export DISPLAY=:99
Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
@@ -167,6 +188,8 @@ build() {
}
package() {
+ export DEBIAN_BUILD="mozilla-release"
+
cd "$srcdir/$DEBIAN_BUILD"
make -f client.mk DESTDIR="$pkgdir" install