summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 87cd20cb3..e26a8d986 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -20,17 +20,18 @@
# parabola changes and rationale:
# - rebranded to iceweasel
+# - changed to release tarball from repo checkout
# - removed google api keys and usage
+# - removed use of firefox-symbolic.svg
# - using tarball instead of repository
# - added makedepends: mozilla-searchplugins, quilt, libxslt, imagemagick
-# - removed makedepends: mercurial
# - added replaces, conflicts and provides: firefox
_pkgname=firefox
pkgname=iceweasel
epoch=1
-pkgver=58.0
-pkgrel=5.1
+pkgver=58.0.2
+pkgrel=1
_bver=58.0
_brel=1
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
@@ -40,7 +41,7 @@ url="https://wiki.parabola.nu/$pkgname"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
nss hunspell sqlite ttf-font libpulse libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm jack mozilla-searchplugins quilt libxslt imagemagick)
+ autoconf2.13 rust mercurial clang llvm jack mozilla-searchplugins quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -50,12 +51,14 @@ replaces=("$_pkgname")
conflicts=("$_pkgname")
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
+ 0001-Bug-1430274-Define-MOZ_ALSA-for-more-source-files.-r.patch
$pkgname-install-dir.patch no-crmf.diff
https://repo.parabola.nu/other/iceweasel/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
libre.patch)
-sha256sums=('0e0a39caabf94d7467d8bb4008fa9e7340a7be57b8c78ccf0cf98791a3bfaaff'
+sha256sums=('2b7794e4c2a24fa388f3acb2956c96bb2c3eae455467f0e386788ebaea7240c3'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
- '46e588300797bda599c8f5157437fd79f88b6e1179f2fde49e0405e435e03efa'
+ 'e8a695bd6a007525390c502739c0f00d5d753a1bde7053c21c712075f2c2994d'
+ 'a94f80abe65608cd49054a30acc31e4d0885fe5b2a38cf08ded5e5b51b87c99d'
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
'482cfe2d92f0b9638061eaf1b457abe0a8c8a0521bd67767e5c5010868612d25'
'SKIP'
@@ -69,6 +72,9 @@ prepare() {
cd "$srcdir/$_pkgname-$pkgver"
patch -Np1 -i ../$pkgname-install-dir.patch
+ # https://bugs.archlinux.org/task/57285
+ patch -Np1 -i ../0001-Bug-1430274-Define-MOZ_ALSA-for-more-source-files.-r.patch
+
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff