summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 7f791a7d7..6800006a0 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -60,10 +60,10 @@
pkgname=iceweasel
epoch=1
-pkgver=101.0.1
+pkgver=102.0
pkgrel=1
pkgrel+=.parabola1
-_brandingver=98.0-1
+_brandingver=102.0-1
pkgdesc="Standalone web browser derived from Mozilla Firefox"
arch=(x86_64)
arch+=(armv7h i686)
@@ -85,6 +85,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
replaces=('firefox')
options=(!emptydirs !makeflags !strip !lto !debug) # FIXME: can we still make debug package?
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
+ zstandard-0.18.0.diff
$pkgname.desktop identity-icons-brand.svg)
source=(${source[*]/identity-icons-brand.svg/})
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}.branding.tar.xz{,.sig}
@@ -98,12 +99,13 @@ source_armv7h=(build-arm-libopus.patch)
source_i686=('avoid-libxul-OOM-python-check.patch'
'rust-static-disable-network-test-on-static-libraries.patch'
'firefox-99.0.1-fdlibm-double.patch')
-sha256sums=('b4c76e8bdf81f473f3e56b2f69dbe5119bba5cab38e36ab0f3f38cf0cdc4a9c2'
+sha256sums=('01797f04bd8d65f4c7f628d7ce832bf52a0874433886e4d0d78ef33c1ca66abf'
'SKIP'
+ 'a6857ad2f2e2091c6c4fdcde21a59fbeb0138914c0e126df64b50a5af5ff63be'
'9cdc2602661717712092d28bb494e5b48e518cb930898aca85eaf21f91f7ef58')
-sha256sums+=('f3e89499909b172476e931d9ab18b856d0001e3042b3816d1728809536179768'
+sha256sums+=('d29c194ed7b3b4fa0f511866723118938c2be40077b4e9aadf8b3e6bfff91049'
'SKIP'
- 'f49bb26d1a04145c39639200b64fd9010ded4261f60e06eb48bc0d5f58d1e935'
+ '77b79ce95a560d371b08925a4f8c005b38e45936f61c8e4a4378d5ac56313cba'
'a2c71759290dd48c87bf8aacb681040dcaefdabe0d57317de361d2d2d509664b'
'e192458a2a9878483984e1400bb3c66df369adfbf6f144b90445f80973c32ed1'
'a6a0bf8296d42a0ea2664efd45e9131df1f19fc6199724ec78d66119589850dd'
@@ -196,6 +198,9 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
+ # Unbreak build with python-zstandard 0.18.0
+ patch -Np1 -i ../zstandard-0.18.0.diff
+
# echo -n "$_google_api_key" >google-api-key # anti-feature
# echo -n "$_mozilla_api_key" >mozilla-api-key # anti-feature
@@ -246,11 +251,9 @@ ac_add_options --disable-eme
END
- # FIXME: FTBS with cbindgen > 0.23
+ # FIXME: FTBS with cbindgen > 0.23 (currrently 0.24)
# https://bugzilla.mozilla.org/show_bug.cgi?id=1773259
- if [[ "${CARCH}" != i686 ]] # cbindgen i686 is currrently 0.23
- then sed -i '/const uint64_t ROOT_CLIP_CHAIN = ~0;/d' gfx/webrender_bindings/webrender_ffi.h
- fi
+ sed -i '/const uint64_t ROOT_CLIP_CHAIN = ~0;/d' gfx/webrender_bindings/webrender_ffi.h
## [ARCH-SPECIFIC CONFIG] ##
@@ -440,7 +443,7 @@ END
# Disable/neutralize Remote Settings (as best we can)
echo "applying 9001-FSDG-sync-remote-settings-with-local-dump.patch"
- patch -Np1 --no-backup-if-mismatch -i ../9001-FSDG-sync-remote-settings-with-local-dump.patch
+ git apply ../9001-FSDG-sync-remote-settings-with-local-dump.patch
# Disable various components at the source level
sed -i 's/;1/;0/' toolkit/components/telemetry/components.conf