summaryrefslogtreecommitdiff
path: root/libre/kdepim-addons/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/kdepim-addons/PKGBUILD')
-rw-r--r--libre/kdepim-addons/PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/libre/kdepim-addons/PKGBUILD b/libre/kdepim-addons/PKGBUILD
index 6ee519e27..a4122737d 100644
--- a/libre/kdepim-addons/PKGBUILD
+++ b/libre/kdepim-addons/PKGBUILD
@@ -1,23 +1,27 @@
-# $Id: PKGBUILD 290221 2017-03-09 16:12:45Z arojas $
+# Maintainer: Andreas Grapentin <andreas@grapentin.org>
# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: jc_gargma <jc_gargma@iserlohn-fortress.net>
pkgname=kdepim-addons
-pkgver=17.04.3
+
+pkgver=17.08.3
pkgrel=1.parabola1
-pkgdesc='Addons for KDE PIM applications (built without nonfree qt5-webengine)'
arch=(i686 x86_64 armv7h)
-url='https://community.kde.org/KDE_PIM'
+
+pkgdesc="Addons for KDE PIM applications (built without nonfree qt5-webengine)"
+url="https://community.kde.org/KDE_PIM"
license=(GPL LGPL FDL)
-depends=(mailcommon incidenceeditor libktnef libksieve akonadi-notes)
+
+depends=(incidenceeditor libktnef libksieve akonadi-notes akonadi-import-wizard)
makedepends=(extra-cmake-modules kdoctools boost python kdesignerplugin)
groups=(kde-applications kdepim)
+
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
'libre.patch')
-sha512sums=('7cccf4906dfa43fd12e3971ebf67494986084d364be0bbbacd1d64274851f0f32621811e8a4a5ab5038d2c3c820028d9e0fbc73d0bd5267eeb094fb17a36772b'
+sha256sums=('9d3c674320b311f5107dd6292760a74ceab84107800e23df16e8091e697e18e4'
'SKIP'
- '0e422fcdb3fe2c250977906aec6f46b055c082954c5a9d4c25c37a8ee306ab92090f2ab22596107f7b905c81d09ca3a314dc2e81bc46bb539a18a0775c820569')
+ '6a8dafaedbdc3c5f19fd2b59459b54c25e0df35e5c6602f49ef75a7e5dbf2bf6')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
@@ -34,7 +38,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib
make
}