summaryrefslogtreecommitdiff
path: root/libre/kdevelop/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/kdevelop/PKGBUILD')
-rw-r--r--libre/kdevelop/PKGBUILD135
1 files changed, 107 insertions, 28 deletions
diff --git a/libre/kdevelop/PKGBUILD b/libre/kdevelop/PKGBUILD
index c8934270b..91d2c316b 100644
--- a/libre/kdevelop/PKGBUILD
+++ b/libre/kdevelop/PKGBUILD
@@ -1,57 +1,136 @@
# Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+# Contributor: bill-auger <bill-auger@programmer.net>
+# Contributor: SolveFinder <kwopleq@proton.me>
# parabola changes and rationale:
-# - build without qt5-webengine
+# - replace 'qt5-webengine' dependency with 'qt5-webkit'
+# - pin to strongly-coupled dependency versions
pkgname=kdevelop
-pkgver=5.6.2
-_clangver=13.0.0
-[[ "${CARCH}" == 'i686' ]] && _clangver=12.0.1
-pkgrel=6
+pkgver=24.02.0
+_clangver=17.0.6
+[[ "${CARCH}" == i686 ]] && _clangver=15.0.7
+pkgrel=2
pkgrel+=.parabola1
pkgdesc='C++ IDE using KDE technologies'
arch=(x86_64)
arch+=(armv7h i686)
url='http://www.kdevelop.org/'
+# license=(GPL-2.0-or-later) # TODO:
license=(GPL)
-depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2
- kcmutils threadweaver knewstuff)
-makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta boost purpose subversion astyle)
-optdepends=('konsole: embedded terminal'
- 'git: Git support' 'subversion: SVN support'
- 'gdb: GNU debugger support' 'lldb: LLDB debugger support'
- 'qt5-doc: Qt documentation integration'
+depends=(clang=$_clangver
+ gcc-libs
+ glibc
+ grantlee
+ karchive5
+ kbookmarks5
+ kcmutils5
+ kcodecs5
+ kcompletion5
+ kconfig5
+ kconfigwidgets5
+ kcoreaddons5
+ kcrash5
+ kdeclarative5
+ kguiaddons5
+ ki18n5
+ kiconthemes5
+ kio5
+ kitemmodels5
+ kitemviews5
+ kjobwidgets5
+ knewstuff5
+ knotifications5
+ knotifyconfig5
+ kparts5
+ kservice5
+ ktexteditor5
+ ktextwidgets5
+ kwidgetsaddons5
+ kwindowsystem5
+ kxmlgui5
+ libkomparediff2
+# libksysguard
+ qt5-base
+ qt5-declarative
+ qt5-webengine
+ sh
+ sonnet5
+ syntax-highlighting5
+ threadweaver5)
+depends=( ${depends[*]/qt5-webengine/qt5-webkit} )
+makedepends=(astyle
+ boost
+ extra-cmake-modules
+ kdevelop-pg-qt
+ kdoctools5
+# krunner5
+ llvm
+ okteta
+ plasma-framework5
+ purpose5
+ qt5-tools
+ subversion)
+optdepends=('apr: SVN support'
+ 'apr-util: SVN support'
+ 'astyle: astyle plugin'
+ 'clazy: clazy analyzer plugin'
'cmake: cmake integration'
+ 'cppcheck: code analyzer'
+ 'gdb: GNU debugger support'
+ 'git: Git support'
+ 'heaptrack: memory profiler'
+ 'kate: for additional plugins'
+ 'kio5-extras: man pages plugin'
+ 'konsolepart5: embedded terminal'
+ 'lldb-mi: LLDB debugger support'
'meson: meson integration'
- 'qt5-tools: qthelp plugin'
'okteta: GNU debugger support'
- 'plasma-framework: for the plasma addons'
- 'purpose: patch review plugin'
- 'astyle: astyle plugin'
- 'cppcheck: code analyzer' 'heaptrack: memory profiler'
- 'clazy: clazy analyzer plugin')
-conflicts=(kdevelop-qmljs kdevplatform)
-replaces=(kdevelop-qmljs kdevplatform kdevelop-clang-tidy)
-source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('0f86bc3fe53f761c1e3e3f7544577a0c41433be8bff310cf2e729f76f4363bf6'
+ 'plasma-framework5: for the plasma addons'
+ 'purpose5: patch review plugin'
+ 'python: debugger support'
+ 'subversion: SVN support'
+ 'qt5-doc: Qt documentation integration'
+ 'qt5-tools: qthelp plugin'
+ 'subversion: SVN support')
+groups=(kde-applications
+ kdevelop)
+source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
+sha256sums=('202acdfb53b1bdeeb9915eab1a0056d190040d8809038950bf2ec8d44fa81e19'
'SKIP')
-validpgpkeys=('329FD02C5AA48FCC77A4BBF0AC44AC6DB29779E6' # Sven Brauch <mail@svenbrauch.de>
- '364EFA5F639572907D392999C64CF56B13CACE5D' # Kevin Funk <kfunk@kde.org>
- 'E191FD5BE6F46870F09E82B2024E7FB43D015474' # Friedrich W. H. Kossebau <kossebau@kde.org>
- '0A48BC961075B4BA8523E3790A345FB086E797D9' # https://share.kde.org/s/8dKaJTw8pR8iiwJ
- 'C51B45A532F17FA401D099A0A0C6B72C4F1C5E7C') # Milian Wolff <mail@milianw.de>
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
+ D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
+
+
+## dependency tweaks ##
+
+case "${CARCH}" in
+i686) # arch32 has not renamed these k*5 packages yet
+ depends=( ${depends[*]%5} )
+ makedepends=( ${makedepends[*]%5} )
+ optdepends=( "${optdepends[@]/kio5-extras:/kio-extras:}" )
+ optdepends=( "${optdepends[@]/konsolepart5:/konsolepart:}" )
+ optdepends=( "${optdepends[@]/plasma-framework5:/plasma-framework:}" )
+ optdepends=( "${optdepends[@]/purpose5:/purpose:}" )
+ ;;
+esac
+
build() {
cmake -B build -S $pkgname-$pkgver \
- -Wno-dev \
-DBUILD_TESTING=OFF
cmake --build build
}
package() {
+ # pin to strongly-coupled dependency versions
+ depends+=( libicu{data,i18n,uc}.so ) # dependency is via qt5-webkit->icu
+
DESTDIR="$pkgdir" cmake --install build
}