summaryrefslogtreecommitdiff
path: root/libre/libosinfo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libosinfo/PKGBUILD')
-rw-r--r--libre/libosinfo/PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/libre/libosinfo/PKGBUILD b/libre/libosinfo/PKGBUILD
index fb7c6821b..880554fac 100644
--- a/libre/libosinfo/PKGBUILD
+++ b/libre/libosinfo/PKGBUILD
@@ -1,30 +1,34 @@
# $Id: PKGBUILD 191823 2016-10-10 10:17:01Z bgyorgy $
# Maintainer (Arch): Balló György <ballogyor+arch at gmail dot com>
# Contributor (Arch): Stefano Facchini <stefano.facchini@gmail.com>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Daniel Milewski <niitotantei@gmail.com>
pkgname=libosinfo
-pkgver=1.0.0
-pkgrel=1.parabola2
+pkgver=1.1.0
+pkgrel=1.parabola1
pkgdesc="GObject based library API for managing information about operating systems, hypervisors and the (virtual) hardware devices they can support, without non-FSDG compliant distros and operating systems support"
arch=('i686' 'x86_64' 'armv7h')
url="http://libosinfo.org/"
license=('GPL' 'LGPL')
depends=('glib2' 'libxslt' 'osinfo-db')
-makedepends=('check' 'gobject-introspection' 'intltool' 'libsoup' 'vala')
+makedepends=('check' 'gobject-introspection' 'intltool' 'libsoup' 'vala' 'gtk-doc')
conflicts=(${pkgname}-libre)
replaces=(${pkgname}-libre)
options=('!libtool')
-source=(https://fedorahosted.org/releases/l/i/$pkgname/$pkgname-$pkgver.tar.gz
+source=(https://releases.pagure.org/libosinfo/$pkgname-$pkgver.tar.gz{,.asc}
libre.patch)
-sha256sums=('f7b425ecde5197d200820eb44401c5033771a5d114bd6390230de768aad0396b'
- '5120733768a39b24a02d19f2c4aa7d8e827dfee1aeefe2e2e6fe48f1ebcf4ce5')
+validpgpkeys=('DAF3A6FDB26B62912D0E8E3FBE86EBB415104FDF') # Daniel P. Berrange
+sha256sums=('600f43a4a8dae5086a01a3d44bcac2092b5fa1695121289806d544fb287d3136'
+ 'SKIP'
+ 'a0465c4f4c5ae1dd8559b0262475202cbca54a85deb4eb2138978d9175ed478d')
prepare() {
cd $pkgname-$pkgver
+ sed -i '/export LC_ALL = C/d' maint.mk
- rm -rv {docs,test/isodata/*}
+ rm -rv {docs,tests/isodata/*}
patch -Np1 -i ../libre.patch
@@ -39,7 +43,8 @@ build() {
cd $pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--with-usb-ids-path=/usr/share/hwdata/usb.ids \
- --with-pci-ids-path=/usr/share/hwdata/pci.ids
+ --with-pci-ids-path=/usr/share/hwdata/pci.ids \
+ --enable-gtk-doc
make
}