summaryrefslogtreecommitdiff
path: root/libre/libosinfo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libosinfo/PKGBUILD')
-rw-r--r--libre/libosinfo/PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/libre/libosinfo/PKGBUILD b/libre/libosinfo/PKGBUILD
index 11b081ba6..93768d17c 100644
--- a/libre/libosinfo/PKGBUILD
+++ b/libre/libosinfo/PKGBUILD
@@ -5,30 +5,37 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Daniel Milewski <niitotantei@gmail.com>
+_pkgname=libosinfo-libre
pkgname=libosinfo
-pkgver=1.1.0
-pkgrel=1.parabola2
+pkgver=1.2.0
+pkgrel=1.parabola1
pkgdesc="GObject based library API for managing information about operating systems, hypervisors and the (virtual) hardware devices they can support, without non-FSDG compliant distros and operating systems support"
arch=('i686' 'x86_64' 'armv7h')
-url="http://libosinfo.org/"
+url="https://libosinfo.org/"
license=('GPL' 'LGPL')
depends=('glib2' 'libxslt' 'osinfo-db')
makedepends=('check' 'gobject-introspection' 'intltool' 'libsoup' 'vala' 'gtk-doc')
conflicts=(${pkgname}-libre)
replaces=(${pkgname}-libre)
-options=('!libtool')
-source=(https://releases.pagure.org/libosinfo/$pkgname-$pkgver.tar.gz{,.asc}
+mksource=(https://releases.pagure.org/libosinfo/$pkgname-$pkgver.tar.gz{,.asc})
+source=(https://repo.parabola.nu/other/${_pkgname}/${_pkgname}-$pkgver.tar.gz
libre.patch)
validpgpkeys=('DAF3A6FDB26B62912D0E8E3FBE86EBB415104FDF') # Daniel P. Berrange
-sha256sums=('600f43a4a8dae5086a01a3d44bcac2092b5fa1695121289806d544fb287d3136'
- 'SKIP'
- '55f4dad4a25b9235174ed858f4b86c689c0c10e6cc29231e5a4598f42af6b4b2')
+mksha256sums=('ee254fcf3f92447787a87b3f6df190c694a787de46348c45101e8dc7b29b5a78'
+ 'SKIP')
+sha256sums=('6abe6b8bb3fdfaf748751c24bec5fb446723505e799024fabde9f5ecb7102482'
+ '896216d2f132ff772b3c0cd9e18aa6c45aca2365767fc0c3aa98e8d3a21ca063')
+
+mksource() {
+ cd $pkgname-$pkgver
+ rm -rv {docs,tests/isodata/*}
+}
prepare() {
cd $pkgname-$pkgver
sed -i '/export LC_ALL = C/d' maint.mk
- rm -rv {docs,tests/isodata/*}
+# rm -rv {docs,tests/isodata/*}
patch -Np1 -i ../libre.patch
@@ -50,8 +57,7 @@ build() {
check() {
cd $pkgname-$pkgver
- # Fails on test-isodetect
- # make check
+ make check || :
}
package() {