summaryrefslogtreecommitdiff
path: root/libre/libretools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libretools/PKGBUILD')
-rw-r--r--libre/libretools/PKGBUILD107
1 files changed, 50 insertions, 57 deletions
diff --git a/libre/libretools/PKGBUILD b/libre/libretools/PKGBUILD
index 423a7bb20..5b4d02fcb 100644
--- a/libre/libretools/PKGBUILD
+++ b/libre/libretools/PKGBUILD
@@ -2,59 +2,49 @@
# Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
pkgbase=libretools
pkgname=(libretools librelib gitget)
+pkgver=20240403
+_pacman_constraints=( 'pacman<6.2' )
+pkgrel=1
pkgdesc="Programs for Parabola development"
-url="https://git.parabola.nu/packages/libretools.git/"
-license=('GPL3' 'GPL2')
-
-pkgver=20181004
-source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
- 0001-libremakepkg-rw-startdir.patch
- 0002-libremakepkg-pacman_5_2.patch)
-sha256sums=('2bdefd1803ba3e6cbd1eb955fad3de9ce8a4abfd23a0bd96a60772762df7b53b'
- 'SKIP'
- '19ed0fd21c9c789dd336b63b22094c45363b6ac5d7d1ab0eecd852d7f00d1883'
- '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
-validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
-
-pkgrel=6.1
arch=('any')
-makedepends=(ruby-ronn)
+url="https://git.parabola.nu/packages/libretools.git/"
+# license=(GPL-2.0-only GPL-3.0-or-later) # TODO:
+license=('GPL2' 'GPL3')
+
+makedepends=(ruby-ronn-ng)
checkdepends=(
- bash-bats git
- 'pacman>=5.1.1-1.parabola5' 'pacman<5.3'
+ bats
+ git
+ "${_pacman_constraints[@]}"
expac
openssh
rsync
tokyocabinet
)
-prepare() {
- cd "$srcdir/$pkgbase-$pkgver"
- patch -N -p1 -i $srcdir/0001-libremakepkg-rw-startdir.patch
- patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
-}
+source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
+sha256sums=('210fecb2c5113818c685e90dc7e67f0f64995142cecc5eed1ac1284589d5840e'
+ 'SKIP')
+validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
+ '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
+ 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
+ '3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
build() {
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
make
}
check() {
- cd "$srcdir/$pkgbase-$pkgver"
- # FIXME as soon as possible
- # we needed to unbreak kernel builds, but tests were failing
- # with the stock PKGBUILD like this:
- # | not ok 13 libreblacklist works with everything set
- # | # (in test file cases/lib-blacklist.bats, line 15)
- # | # `v="$(libreblacklist get-rep <<<"$line")"; [[ $v == 'libre/linux-libre' ]]' failed
- # | # gpg: Warning: using insecure memory!
- # | # gpg: key 57169AAE979EC3AB marked as ultimately trusted
- # | # gpg: Warning: using insecure memory!
- # | # OK closing connection
- # SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
+ cd "$srcdir"/$pkgbase-$pkgver
+
+ SUDO_USER= make check BATS_FLAGS='--filter-tags !network,!sudo'
}
package_librelib() {
@@ -66,7 +56,8 @@ package_librelib() {
'wget: for libreblacklist/blacklist.sh'
)
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
make install-librelib DESTDIR="$pkgdir"
}
@@ -75,11 +66,8 @@ package_gitget() {
license=(GPL2)
depends=("librelib=$pkgver" git)
- provides=("libregit=$pkgver")
- conflicts=("libregit")
- replaces=("libregit")
+ cd "$srcdir"/$pkgbase-$pkgver
- cd "$srcdir/$pkgbase-$pkgver"
make install-gitget DESTDIR="$pkgdir"
}
@@ -89,30 +77,35 @@ package_libretools() {
etc/libretools.d/libredbdiff.conf
etc/libretools.d/librefetch.conf)
install=libretools.install
- conflicts=(devtools libretools-mips64el)
- replaces=(libretools-mips64el)
+ conflicts=(devtools)
depends=(
- "librelib=$pkgver"
- "gitget=$pkgver" # `createworkdir`
- 'pacman>=5.1.1-1.parabola5' 'pacman<5.3'
arch-install-scripts # `mkarchroot` uses `pacstrap`
- binutils # `libremakepkg` uses `makepkg` uses `strip`
- expac # `libredbdiff`
- fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
- make # `librefetch`
- openssh # `librerelease`
- rsync # `librerelease` and `makechrootpkg.sh`
- 'systemd-tools>=234' # systemd-nspawn
- tokyocabinet # `toru`
- #namcap # Namcap is currently dissabled in libremakepkg :-(
- subversion # `diff-unfree`
- wget # `aur`, optdepend for librelib:`blacklist`
+ binutils # `libremakepkg`->`makepkg` uses `strip`
+ expac # `libredbdiff`
+ fakeroot # `libremakepkg`->`makepkg` uses `fakeroot`
+ make # `librefetch`
+ openssh # `librerelease`
+ pacutils # `librechroot` uses `pacsift`
+ rsync # `librerelease` and `makechrootpkg.sh`
+ tokyocabinet # `toru`
+ namcap # `libremakepkg`
+ subversion # `diff-unfree`
+ wget # `aur`, optdepend for librelib:`blacklist`
)
+ depends+=( # pinned dependencies
+ "librelib=$pkgver"
+ "gitget=$pkgver" # `createworkdir`
+ "${_pacman_constraints[@]}"
+ 'systemd-tools>=234' # `systemd-nspawn` # TODO: merge 'nonsystemd' branch
+ )
+ depends=( ${depends[*]/pacutils/} ) # WIP
+ depends=( ${depends[*]/namcap/} ) # FIXME: Namcap is currently disabled in libremakepkg :-(
optdepends=(
'qemu-user-static-binfmt: To build ARM packages from x86'
)
- cd "$srcdir/$pkgbase-$pkgver"
+ cd "$srcdir"/$pkgbase-$pkgver
+
make install-libretools DESTDIR="$pkgdir"
}