summaryrefslogtreecommitdiff
path: root/libre/libretools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libretools/PKGBUILD')
-rw-r--r--libre/libretools/PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/libre/libretools/PKGBUILD b/libre/libretools/PKGBUILD
index 49dc7feb2..80b154dff 100644
--- a/libre/libretools/PKGBUILD
+++ b/libre/libretools/PKGBUILD
@@ -4,13 +4,13 @@
# Contributor: Márcio Silva <coadde@lavabit.com>
pkgbase=libretools
-pkgname=(libretools libretools-mips64el)
+pkgname=(libretools libretools-mips64el librelib)
pkgdesc="Programs for Parabola development"
url="https://projects.parabolagnulinux.org/packages/libretools.git/"
license=('GPL3' 'GPL2')
-pkgver=20130611
-_libretools_commit=e6944bc03f587ad177c6b825e3f4c116fb9b9b12
+pkgver=20130627
+_libretools_commit=08375ed421d18b48388169c7fc7cf4ca076577ba
_devtools_commit=bf8513ae631484a0c292ad085ea7ede9859f8e0f
_packages_url=https://projects.parabolagnulinux.org/packages
@@ -26,7 +26,7 @@ build() {
cd "$srcdir"
ln -sf devtools-par-$_devtools_commit devtools-par
cd "$srcdir/$pkgbase-$_libretools_commit"
- make build-libretools build-libretools-mips64el build-doc
+ make build-libretools build-libretools-mips64el build-librelib build-doc
}
check() {
@@ -35,6 +35,16 @@ check() {
make check TESTENVFLAGS='--no-network --no-sudo'
}
+package_librelib() {
+ pkgdesc="Shell library portion of libretools"
+ depends=(
+ wget # `aur` and `lib/blacklist.sh`
+ )
+
+ cd "$srcdir/$pkgbase-$_libretools_commit"
+ make install-librelib DESTDIR="$pkgdir"
+}
+
package_libretools() {
backup=(etc/libretools.conf etc/libretools.d/chroot.conf etc/libretools.d/librefetch.conf)
install=libretools.install
@@ -42,13 +52,13 @@ package_libretools() {
conflicts=(devtools)
depends=(
+ "librelib=$pkgver"
arch-install-scripts # `archroot` uses `pacstrap`
git # `createworkdir` (also mips-add in -mips64el)
openssh # `librerelease`
rsync # `librerelease` and `makechrootpkg.sh`
subversion # `diff-unfree`
tokyocabinet # `treepkg`
- wget # `aur` and `lib/blacklist.sh`
)
optdepends=('namcap: to check package files')
@@ -64,5 +74,5 @@ package_libretools-mips64el() {
make install-libretools-mips64el DESTDIR="$pkgdir"
}
-md5sums=('3d5645488481fab48954e194274f70ac'
+md5sums=('acbdcd22c1b922f943651dbf7c320bbd'
'b28b1492fda205be7c577fc03cbc3399')