summaryrefslogtreecommitdiff
path: root/libre/libutil-linux-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libutil-linux-static/PKGBUILD')
-rw-r--r--libre/libutil-linux-static/PKGBUILD65
1 files changed, 0 insertions, 65 deletions
diff --git a/libre/libutil-linux-static/PKGBUILD b/libre/libutil-linux-static/PKGBUILD
deleted file mode 100644
index 14bf874a3..000000000
--- a/libre/libutil-linux-static/PKGBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Maintainer: Tom Gundersen <teg@jklm.no>
-# Maintainer: Dave Reisner <dreisner@archlinux.org>
-# Contributor: judd <jvinet@zeroflux.org>
-
-_pkgbase=util-linux
-pkgname=libutil-linux-static
-_pkgmajor=2.33
-pkgver=${_pkgmajor}.1
-pkgrel=2
-pkgrel+=.static1
-pkgdesc="Miscellaneous system utilities for Linux"
-url="https://www.kernel.org/pub/linux/utils/util-linux/"
-arch=('x86_64')
-arch+=('i686' 'armv7h')
-makedepends=('systemd' 'python' 'libcap-ng')
-license=('GPL2')
-options=('strip' 'debug')
-validpgpkeys=('B0C64D14301CC6EFAEDF60E4E4B71D5EEC39C284') # Karel Zak
-source=("https://www.kernel.org/pub/linux/utils/util-linux/v$_pkgmajor/$_pkgbase-$pkgver.tar."{xz,sign}
- pam-{login,common,runuser,su}
- 'util-linux.sysusers'
- '60-rfkill.rules'
- 'rfkill-unblock_.service'
- 'rfkill-block_.service')
-sha256sums=('c14bd9f3b6e1792b90db87696e87ec643f9d63efa0a424f092a5a6b2f2dbef21'
- 'SKIP'
- '993a3096c2b113e6800f2abbd5d4233ebf1a97eef423990d3187d665d3490b92'
- 'fc6807842f92e9d3f792d6b64a0d5aad87995a279153ab228b1b2a64d9f32f20'
- '95b7cdc4cba17494d7b87f37f8d0937ec54c55de0e3ce9d9ab05ad5cc76bf935'
- '51eac9c2a2f51ad3982bba35de9aac5510f1eeff432d2d63c6362e45d620afc0'
- '10b0505351263a099163c0d928132706e501dd0a008dac2835b052167b14abe3'
- '7423aaaa09fee7f47baa83df9ea6fef525ff9aec395c8cbd9fe848ceb2643f37'
- '8ccec10a22523f6b9d55e0d6cbf91905a39881446710aa083e935e8073323376'
- 'a22e0a037e702170c7d88460cc9c9c2ab1d3e5c54a6985cd4a164ea7beff1b36')
-
-build() {
- cd "$_pkgbase-$pkgver"
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --bindir=/usr/bin \
- --localstatedir=/var \
- --enable-fs-paths-default=/usr/bin:/usr/local/bin \
- --enable-raw \
- --enable-vipw \
- --enable-newgrp \
- --enable-chfn-chsh \
- --enable-write \
- --enable-mesg \
- --disable-shared --enable-static \
- --with-python=3
-
- make
-}
-
-package() {
- pkgdesc="util-linux runtime libraries"
- pkgdesc+=" (static libraries)"
- provides=()
- depends=("libutil-linux=$pkgver")
- options=('staticlibs')
-
- make -C "$_pkgbase-$pkgver" DESTDIR="$pkgdir" install-usrlib_execLTLIBRARIES
-}